summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/miniupnpc/ChangeLog9
-rw-r--r--net-libs/miniupnpc/miniupnpc-1.8.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/net-libs/miniupnpc/ChangeLog b/net-libs/miniupnpc/ChangeLog
index c808f408c118..55bbd32dab33 100644
--- a/net-libs/miniupnpc/ChangeLog
+++ b/net-libs/miniupnpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/miniupnpc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.30 2012/12/16 18:16:50 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.31 2013/02/11 09:51:07 mgorny Exp $
+
+*miniupnpc-1.8 (11 Feb 2013)
+
+ 11 Feb 2013; Michał Górny <mgorny@gentoo.org> +miniupnpc-1.8.ebuild:
+ Version bump.
16 Dec 2012; Raúl Porcel <armin76@gentoo.org> miniupnpc-1.6-r1.ebuild,
miniupnpc-1.6.20120509.ebuild, miniupnpc-1.7.ebuild:
diff --git a/net-libs/miniupnpc/miniupnpc-1.8.ebuild b/net-libs/miniupnpc/miniupnpc-1.8.ebuild
new file mode 100644
index 000000000000..5b7ae6d91b87
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-1.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/miniupnpc-1.8.ebuild,v 1.1 2013/02/11 09:51:07 mgorny Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux static-libs"
+
+# Tests hang trying to kill server, bug #409349
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="kernel_linux? ( sys-apps/lsb-release sys-apps/which )"
+
+src_prepare() {
+ epatch_user
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(INSTALLDIRLIB)/d' \
+ Makefile || die
+ fi
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC
+ emake upnpc-shared $(use static-libs && echo upnpc-static)
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}" \
+ INSTALLDIRLIB="${D}usr/$(get_libdir)" \
+ install
+
+ dodoc README Changelog.txt
+}