summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-11 14:57:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-11 14:57:35 +0000
commitbd120726d4bec530cb1530fdbcc5fb029b77c993 (patch)
tree6b457ec4cd58fc9776a035d0e117321d3e5ee309 /xfce-extra/xfce4-soundmenu-plugin
parentVersion bump. (diff)
downloadgentoo-2-bd120726d4bec530cb1530fdbcc5fb029b77c993.tar.gz
gentoo-2-bd120726d4bec530cb1530fdbcc5fb029b77c993.tar.bz2
gentoo-2-bd120726d4bec530cb1530fdbcc5fb029b77c993.zip
Optionalize dev-libs/keybinder with USE="keybinder"
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra/xfce4-soundmenu-plugin')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/metadata.xml1
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild11
3 files changed, 13 insertions, 7 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
index fa69f6f12703..1ef52ee44b96 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-soundmenu-plugin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.23 2013/05/05 17:18:11 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.24 2014/04/11 14:57:35 ssuominen Exp $
+
+ 11 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml,
+ xfce4-soundmenu-plugin-0.6.0.ebuild:
+ Optionalize dev-libs/keybinder with USE="keybinder"
05 May 2013; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-soundmenu-plugin-0.4.10.ebuild:
diff --git a/xfce-extra/xfce4-soundmenu-plugin/metadata.xml b/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
index 19f5f9a432bc..f7aa09c01556 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
+++ b/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
@@ -5,5 +5,6 @@
<use>
<flag name='glyr'>Enable music metadata searchengine support using <pkg>media-libs/glyr</pkg></flag>
<flag name='lastfm'>Enable last.fm support using <pkg>media-libs/libclastfm</pkg></flag>
+ <flag name='keybinder'>Enable shortcut support using <pkg>dev-libs/keybinder</pkg></flag>
</use>
</pkgmetadata>
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
index 0f7f602404a6..90602a7c8c1f 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild,v 1.3 2013/04/11 18:07:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild,v 1.4 2014/04/11 14:57:35 ssuominen Exp $
EAPI=5
inherit xfconf
@@ -12,17 +12,17 @@ SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug +glyr lastfm"
+IUSE="debug +glyr lastfm +keybinder"
RDEPEND=">=dev-libs/glib-2.28
- >=dev-libs/keybinder-0.2.2:0
>=x11-libs/gtk+-2.20:2
x11-libs/libX11
>=xfce-base/libxfce4ui-4.10
>=xfce-base/libxfce4util-4.10
>=xfce-base/xfce4-panel-4.10
glyr? ( >=media-libs/glyr-1.0.0 )
- lastfm? ( >=media-libs/libclastfm-0.5 )"
+ lastfm? ( >=media-libs/libclastfm-0.5 )
+ keybinder? ( >=dev-libs/keybinder-0.2.2:0 )"
DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
XFCONF=(
+ $(use_enable keybinder)
$(use_enable lastfm libclastfm)
$(use_enable glyr libglyr)
$(xfconf_use_debug)