summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-15 03:49:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-15 03:49:00 +0000
commit8b95b18d3b4b086b3f2ad8efa73fa648e280f430 (patch)
tree3f4dacc6e0adbf638addf33f399ed722e0c0271e /xfce-extra/xfce4-soundmenu-plugin
parentAdd file collision avoidance logic by Samuli Suominen in bug 408249 (diff)
downloadgentoo-2-8b95b18d3b4b086b3f2ad8efa73fa648e280f430.tar.gz
gentoo-2-8b95b18d3b4b086b3f2ad8efa73fa648e280f430.tar.bz2
gentoo-2-8b95b18d3b4b086b3f2ad8efa73fa648e280f430.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-soundmenu-plugin')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
index 0dc44bc6f738..d20de58a2f5f 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-soundmenu-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.7 2012/02/10 12:29:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.8 2012/03/15 03:49:00 ssuominen Exp $
+
+*xfce4-soundmenu-plugin-0.4.1 (15 Mar 2012)
+
+ 15 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-soundmenu-plugin-0.4.1.ebuild:
+ Version bump.
10 Feb 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-soundmenu-plugin-0.2.4.2.ebuild:
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.1.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.1.ebuild
new file mode 100644
index 000000000000..a764b4cceaf6
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.1.ebuild,v 1.1 2012/03/15 03:49:00 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="https://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="mirror://github/matiasdelellis/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm"
+
+RDEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/keybinder-0.2.2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ glyr? ( >=media-libs/glyr-0.9.4 )
+ lastfm? ( >=media-libs/libclastfm-0.4_p2012 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-static
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}