summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-28 10:21:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-28 10:21:02 +0000
commit3081713ad9cc87f3752f08cab60d9630d7d1e799 (patch)
tree3d1857d9a84f628372efa136d57e6cfd067a1434 /xfce-extra/xfce4-netload-plugin
parentFix PYTHON_COMPAT (#478442 by Alphat-PC) (diff)
downloadgentoo-2-3081713ad9cc87f3752f08cab60d9630d7d1e799.tar.gz
gentoo-2-3081713ad9cc87f3752f08cab60d9630d7d1e799.tar.bz2
gentoo-2-3081713ad9cc87f3752f08cab60d9630d7d1e799.zip
Increase the max. length of the interface names wrt #478454 by Florian Berger
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra/xfce4-netload-plugin')
-rw-r--r--xfce-extra/xfce4-netload-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-netload-plugin/files/xfce4-netload-plugin-1.2.0-interface_name_length.patch36
-rw-r--r--xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild32
3 files changed, 77 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-netload-plugin/ChangeLog b/xfce-extra/xfce4-netload-plugin/ChangeLog
index f9b685979c43..38db38012ea9 100644
--- a/xfce-extra/xfce4-netload-plugin/ChangeLog
+++ b/xfce-extra/xfce4-netload-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-netload-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netload-plugin/ChangeLog,v 1.32 2012/11/28 12:24:57 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netload-plugin/ChangeLog,v 1.33 2013/07/28 10:21:02 ssuominen Exp $
+
+*xfce4-netload-plugin-1.2.0-r1 (28 Jul 2013)
+
+ 28 Jul 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-netload-plugin-1.2.0-r1.ebuild,
+ +files/xfce4-netload-plugin-1.2.0-interface_name_length.patch:
+ Increase the max. length of the interface names wrt #478454 by Florian Berger
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-netload-plugin-1.2.0.ebuild:
diff --git a/xfce-extra/xfce4-netload-plugin/files/xfce4-netload-plugin-1.2.0-interface_name_length.patch b/xfce-extra/xfce4-netload-plugin/files/xfce4-netload-plugin-1.2.0-interface_name_length.patch
new file mode 100644
index 000000000000..685efc86adfd
--- /dev/null
+++ b/xfce-extra/xfce4-netload-plugin/files/xfce4-netload-plugin-1.2.0-interface_name_length.patch
@@ -0,0 +1,36 @@
+http://bugs.gentoo.org/478454
+http://bugzilla.xfce.org/show_bug.cgi?id=9807
+
+--- panel-plugin/net.h
++++ panel-plugin/net.h
+@@ -29,7 +29,7 @@
+ #define UP_UPDATE_INTERVAL 20
+ #define IP_UPDATE_INTERVAL 20
+ #define IP_ADDRESS_LENGTH 64
+-#define INTERFACE_NAME_LENGTH 9
++#define INTERFACE_NAME_LENGTH 19
+
+ #ifndef gettext_noop
+ #define gettext_noop(String) String
+--- panel-plugin/netload.c
++++ panel-plugin/netload.c
+@@ -51,7 +51,7 @@
+ static gchar* DEFAULT_COLOR[] = { "#FF4F00", "#FFE500" };
+
+ #define UPDATE_TIMEOUT 250
+-#define MAX_LENGTH 10
++#define MAX_LENGTH 20
+
+ #define IN 0
+ #define OUT 1
+--- panel-plugin/slurm.h
++++ panel-plugin/slurm.h
+@@ -10,7 +10,7 @@
+ #define _SLURM_H_
+
+ typedef struct IfData{
+- char if_name[10]; /* The device name given as start parameter*/
++ char if_name[20]; /* The device name given as start parameter*/
+ int if_speed; /* The Interface speed */
+ char if_speedstring[12]; /* the measuring unit like Mbit, kbit */
+ int if_id; /* The ID which the interface inside the OS has */
diff --git a/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..f06092806899
--- /dev/null
+++ b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild,v 1.1 2013/07/28 10:21:02 ssuominen Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A network load plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfce4-panel-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-interface_name_length.patch )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}