summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-20 13:25:50 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-20 13:25:50 +0000
commit88c2ea863d53383284aef00a5203d7ac01d61509 (patch)
tree72e5baccdf4e46fc642078d3c22fefb30c5f22d0 /xfce-extra/thunar-vcs-plugin
parentFix up broken ChangeLog format (diff)
downloadgentoo-2-88c2ea863d53383284aef00a5203d7ac01d61509.tar.gz
gentoo-2-88c2ea863d53383284aef00a5203d7ac01d61509.tar.bz2
gentoo-2-88c2ea863d53383284aef00a5203d7ac01d61509.zip
Re-import, current version is compatible with Thunar-1.2
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/thunar-vcs-plugin')
-rw-r--r--xfce-extra/thunar-vcs-plugin/ChangeLog10
-rw-r--r--xfce-extra/thunar-vcs-plugin/metadata.xml8
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.4.ebuild38
3 files changed, 56 insertions, 0 deletions
diff --git a/xfce-extra/thunar-vcs-plugin/ChangeLog b/xfce-extra/thunar-vcs-plugin/ChangeLog
new file mode 100644
index 000000000000..8c00368bc7b9
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for xfce-extra/thunar-vcs-plugin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vcs-plugin/ChangeLog,v 1.14 2011/03/20 13:25:50 angelos Exp $
+
+*thunar-vcs-plugin-0.1.4 (20 Mar 2011)
+
+ 20 Mar 2011; Christoph Mende <angelos@gentoo.org>
+ +thunar-vcs-plugin-0.1.4.ebuild, +metadata.xml:
+ Re-import, current version is compatible with Thunar-1.2
+
diff --git a/xfce-extra/thunar-vcs-plugin/metadata.xml b/xfce-extra/thunar-vcs-plugin/metadata.xml
new file mode 100644
index 000000000000..da452d625db8
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+ <use>
+ <flag name="git">Enable <pkg>dev-vcs/git</pkg> support</flag>
+ </use>
+</pkgmetadata>
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.4.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.4.ebuild
new file mode 100644
index 000000000000..fcd3cd0ce6b2
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.4.ebuild,v 1.1 2011/03/20 13:25:50 angelos Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +git +subversion"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/exo-0.6
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/thunar-1.2
+ git? ( dev-vcs/git )
+ subversion? ( >=dev-libs/apr-0.9.7
+ >=dev-vcs/subversion-1.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable subversion)
+ $(use_enable git)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README"
+}