summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-01 16:22:15 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-01 16:22:15 +0000
commitcadd700411cae03aa4f04d80c3ce802a5217be75 (patch)
treeaca33fae5b77779b947f4c582d04423dc571c4d6 /xfce-base
parentversion bump for security bug 545232; remove old (diff)
downloadgentoo-2-cadd700411cae03aa4f04d80c3ce802a5217be75.tar.gz
gentoo-2-cadd700411cae03aa4f04d80c3ce802a5217be75.tar.bz2
gentoo-2-cadd700411cae03aa4f04d80c3ce802a5217be75.zip
Fix build failure with USE=-thunar, bug #544260.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/ChangeLog6
-rw-r--r--xfce-base/xfdesktop/files/xfdesktop-4.12.1-no-thunar-build.patch31
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild6
3 files changed, 41 insertions, 2 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index 5297ecbb61ee..f449fa556e02 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/xfdesktop
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.253 2015/03/22 14:23:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.254 2015/04/01 16:22:15 mgorny Exp $
+
+ 01 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +files/xfdesktop-4.12.1-no-thunar-build.patch, xfdesktop-4.12.1.ebuild:
+ Fix build failure with USE=-thunar, bug #544260.
*xfdesktop-4.12.1 (22 Mar 2015)
diff --git a/xfce-base/xfdesktop/files/xfdesktop-4.12.1-no-thunar-build.patch b/xfce-base/xfdesktop/files/xfdesktop-4.12.1-no-thunar-build.patch
new file mode 100644
index 000000000000..52afb020f5bd
--- /dev/null
+++ b/xfce-base/xfdesktop/files/xfdesktop-4.12.1-no-thunar-build.patch
@@ -0,0 +1,31 @@
+From 71c8754d9978895542cf13eba8958df078a91a6c Mon Sep 17 00:00:00 2001
+From: Thaddaeus Tintenfisch <thad.fisch@gmail.com>
+Date: Sun, 29 Mar 2015 18:36:47 +0200
+Subject: [PATCH] Fix build error (Bug #11778)
+
+---
+ src/xfdesktop-icon-view.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/xfdesktop-icon-view.c b/src/xfdesktop-icon-view.c
+index adff45c..30914c4 100644
+--- a/src/xfdesktop-icon-view.c
++++ b/src/xfdesktop-icon-view.c
+@@ -1640,6 +1640,7 @@ xfdesktop_icon_view_drag_drop(GtkWidget *widget,
+
+ action = gdk_drag_context_get_selected_action(context);
+
++#ifdef ENABLE_FILE_ICONS
+ if(action == GDK_ACTION_ASK) {
+ xfdesktop_dnd_menu(icon_view->priv->manager, icon_on_dest,
+ context, &action, row, col, time_);
+@@ -1649,6 +1650,7 @@ xfdesktop_icon_view_drag_drop(GtkWidget *widget,
+ return ret;
+ }
+ }
++#endif
+
+ for(l = icon_view->priv->selected_icons; l; l = l->next) {
+ if(xfdesktop_icon_do_drop_dest(icon_on_dest,
+--
+2.1.4
diff --git a/xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild
index 6eaca01c3d7c..64610fa70a72 100644
--- a/xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild
+++ b/xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild,v 1.1 2015/03/22 14:23:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.12.1.ebuild,v 1.2 2015/04/01 16:22:15 mgorny Exp $
EAPI=5
inherit xfconf
@@ -38,6 +38,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-no-thunar-build.patch
+ )
+
XFCONF=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
$(use_enable thunar file-icons)