summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2006-12-31 17:34:16 +0000
committerSteve Dibb <beandog@gentoo.org>2006-12-31 17:34:16 +0000
commitada5061e8798e464904a9def6705cb187e3bbdbd (patch)
tree2ead1876b1b21c57b5848f6e71179c0038dee48e /x11-wm
parentppc stable wrt bug #159527 (diff)
downloadgentoo-2-ada5061e8798e464904a9def6705cb187e3bbdbd.tar.gz
gentoo-2-ada5061e8798e464904a9def6705cb187e3bbdbd.tar.bz2
gentoo-2-ada5061e8798e464904a9def6705cb187e3bbdbd.zip
Version bump, remove artwiz-fonts dep, bug 143355
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/ChangeLog7
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.303
-rw-r--r--x11-wm/icewm/icewm-1.2.30.ebuild107
3 files changed, 116 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 55dbce17e3ca..5225a4c2d066 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.120 2006/12/23 20:43:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.121 2006/12/31 17:34:16 beandog Exp $
+
+*icewm-1.2.30 (31 Dec 2006)
+
+ 31 Dec 2006; Steve Dibb <beandog@gentoo.org> +icewm-1.2.30.ebuild:
+ Version bump, remove artwiz-fonts dep, bug 143355
23 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org> icewm-1.2.26.ebuild:
Stable on ppc wrt bug #144723.
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.30 b/x11-wm/icewm/files/digest-icewm-1.2.30
new file mode 100644
index 000000000000..191b31a08926
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.30
@@ -0,0 +1,3 @@
+MD5 8a302c5e629bb81d87cc02004a694ece icewm-1.2.30.tar.gz 809353
+RMD160 6848ac22f6562a8e0bb43def621b26f66bef56a7 icewm-1.2.30.tar.gz 809353
+SHA256 4b802cf77ecf09bc44345f8fba3c11fd08dca0e8272e628b447ecf7289637e1d icewm-1.2.30.tar.gz 809353
diff --git a/x11-wm/icewm/icewm-1.2.30.ebuild b/x11-wm/icewm/icewm-1.2.30.ebuild
new file mode 100644
index 000000000000..71421c170bb6
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.30.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.30.ebuild,v 1.1 2006/12/31 17:34:16 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="Ice Window Manager with Themes"
+
+HOMEPAGE="http://www.icewm.org/"
+
+#fix for icewm preversion package names
+S=${WORKDIR}/${P/_}
+
+SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="esd imlib nls spell truetype xinerama minimal debug"
+
+RDEPEND="|| ( (
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libXt
+ x11-libs/libXdmcp
+ xinerama? ( x11-libs/libXinerama ) )
+ virtual/x11 )
+ esd? ( media-sound/esound )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )
+ media-libs/giflib"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto ) )
+ virtual/x11 )
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+ if use truetype && use minimal; then
+ ewarn "You have both 'truetype' and 'minimal' use flags enabled."
+ ewarn "If you really want a minimal install, you will have to turn off"
+ ewarn "the truetype flag for this package."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ echo "#!/bin/sh" > $T/icewm
+ echo "/usr/bin/icewm-session" >> $T/icewm
+}
+
+src_compile() {
+
+ if use truetype
+ then
+ myconf="${myconf} --enable-gradients --enable-shape --enable-movesize-fx --enable-shaped-decorations"
+ else
+ myconf="${myconf} --disable-xfreetype --enable-corefonts
+ $(use_enable minimal lite)"
+ fi
+
+ myconf="${myconf}
+ --with-libdir=/usr/share/icewm
+ --with-cfgdir=/etc/icewm
+ --with-docdir=/usr/share/doc/${PF}/html
+ $(use_with esd esd-config /usr/bin/esd-config)
+ $(use_enable nls)
+ $(use_enable nls i18n)
+ $(use_with imlib)
+ $(use_enable spell GtkSpell)
+ $(use_enable x86 x86-asm)
+ $(use_enable xinerama)
+ $(use_enable debug)"
+
+ CXXFLAGS="${CXXFLAGS}" econf ${myconf} || die "configure failed"
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die "patch failed"
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS BUGS CHANGES PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ exeinto /etc/X11/Sessions
+ doexe $T/icewm
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/IceWM.desktop
+}