summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-15 07:47:27 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-15 07:47:27 +0000
commitaf5a579d11696b6831a5b170fab93f82d1550c14 (patch)
tree8c51f741ddbb412c3c1988981027cfb27f6c968c /x11-wm/sawfish
parentVersion bump. (diff)
downloadgentoo-2-af5a579d11696b6831a5b170fab93f82d1550c14.tar.gz
gentoo-2-af5a579d11696b6831a5b170fab93f82d1550c14.tar.bz2
gentoo-2-af5a579d11696b6831a5b170fab93f82d1550c14.zip
Version bump.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/sawfish-1.9.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index cb8caebb6371..caac1baf5212 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.111 2012/07/08 12:03:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.112 2012/09/15 07:47:27 pacho Exp $
+
+*sawfish-1.9.1 (15 Sep 2012)
+
+ 15 Sep 2012; Pacho Ramos <pacho@gentoo.org> +sawfish-1.9.1.ebuild:
+ Version bump.
*sawfish-1.9.0 (08 Jul 2012)
diff --git a/x11-wm/sawfish/sawfish-1.9.1.ebuild b/x11-wm/sawfish/sawfish-1.9.1.ebuild
new file mode 100644
index 000000000000..e4b480e2619d
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.9.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.9.1.ebuild,v 1.1 2012/09/15 07:47:27 pacho Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+SRC_URI="http://download.tuxfamily.org/sawfish/${P}.tar.xz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND=">=dev-libs/librep-0.92.1
+ >=x11-libs/rep-gtk-0.90.7
+ >=x11-libs/pango-1.8.0[X]
+ >=x11-libs/gtk+-2.24.0:2
+ x11-libs/libXtst
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+src_configure() {
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+}