summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-10 21:46:34 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-10 21:46:34 +0000
commit563f8bca595e19d266ff13a4c7e3c147509bd923 (patch)
tree02f655eb91400eadbaf777a00b8633d2a8d9ad87 /x11-wm/sawfish
parentFix build failure with automake-1.13.1, bug #469208. (diff)
downloadgentoo-2-563f8bca595e19d266ff13a4c7e3c147509bd923.tar.gz
gentoo-2-563f8bca595e19d266ff13a4c7e3c147509bd923.tar.bz2
gentoo-2-563f8bca595e19d266ff13a4c7e3c147509bd923.zip
Install sawfish mode for Emacs, controlled by USE=emacs, bug 493114.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog8
-rw-r--r--x11-wm/sawfish/files/50sawfish-gentoo.el7
-rw-r--r--x11-wm/sawfish/metadata.xml10
-rw-r--r--x11-wm/sawfish/sawfish-1.9.1-r2.ebuild78
4 files changed, 101 insertions, 2 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 6e05a967b9c0..75e3042edaaf 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/sawfish
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.128 2014/02/09 10:41:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.129 2014/02/10 21:46:34 ulm Exp $
+
+*sawfish-1.9.1-r2 (10 Feb 2014)
+
+ 10 Feb 2014; Ulrich Müller <ulm@gentoo.org> +sawfish-1.9.1-r2.ebuild,
+ +files/50sawfish-gentoo.el, metadata.xml:
+ Install sawfish mode for Emacs, controlled by USE=emacs, bug 493114.
09 Feb 2014; Pacho Ramos <pacho@gentoo.org> -files/libtool.patch,
-files/sawfish-1.3.3-cflags.patch, -files/sawfish-1.3.3-parallel-make.patch,
diff --git a/x11-wm/sawfish/files/50sawfish-gentoo.el b/x11-wm/sawfish/files/50sawfish-gentoo.el
new file mode 100644
index 000000000000..d1b6006e6307
--- /dev/null
+++ b/x11-wm/sawfish/files/50sawfish-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'sawfish-mode "sawfish" nil t)
+(autoload 'sawfish-interaction "sawfish" nil t)
+(autoload 'sawfish-console "sawfish" nil t)
+(add-to-list 'auto-mode-alist '("\\.sawfishrc\\'" . sawfish-mode))
+(add-to-list 'auto-mode-alist '("\\.jl\\'" . sawfish-mode))
+(add-to-list 'auto-mode-alist '("\\.sawfish/rc\\'" . sawfish-mode))
diff --git a/x11-wm/sawfish/metadata.xml b/x11-wm/sawfish/metadata.xml
index 4538a68724a6..cd6c593dee3c 100644
--- a/x11-wm/sawfish/metadata.xml
+++ b/x11-wm/sawfish/metadata.xml
@@ -1,5 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+</maintainer>
+<maintainer>
+ <email>emacs@gentoo.org</email>
+ <description>Components installed with USE=emacs.
+ Do not assign for anything else.</description>
+</maintainer>
</pkgmetadata>
diff --git a/x11-wm/sawfish/sawfish-1.9.1-r2.ebuild b/x11-wm/sawfish/sawfish-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..bbb79fe0ec55
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.9.1-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.9.1-r2.ebuild,v 1.1 2014/02/10 21:46:34 ulm Exp $
+
+EAPI=5
+inherit eutils elisp-common
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+SRC_URI="http://download.tuxfamily.org/sawfish/${P}.tar.xz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls xinerama"
+
+RDEPEND="emacs? ( !app-emacs/sawfish )
+ >=dev-libs/librep-0.92.1
+ >=x11-libs/rep-gtk-0.90.7
+ || ( x11-libs/pangox-compat <x11-libs/pango-1.31[X] )
+ >=x11-libs/gtk+-2.24.0:2
+ x11-libs/libXtst
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix firefox resizing problems, bug #462016
+ epatch "${FILESDIR}/${P}-firefox.patch"
+}
+
+src_configure() {
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_compile() {
+ emake
+ use emacs && elisp-compile sawfish.el
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --modules
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+
+ if use emacs; then
+ elisp-install ${PN} sawfish.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}