summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-11-16 20:11:28 +0000
committerThomas Sachau <tommy@gentoo.org>2012-11-16 20:11:28 +0000
commitcb71258e24bb0765841da15d2474f09a85424bf5 (patch)
treef1fb9a733d29e939939920dc260369a08db0292e /x11-wm/enlightenment
parentworkaround for bug 399061 (diff)
downloadgentoo-2-cb71258e24bb0765841da15d2474f09a85424bf5.tar.gz
gentoo-2-cb71258e24bb0765841da15d2474f09a85424bf5.tar.bz2
gentoo-2-cb71258e24bb0765841da15d2474f09a85424bf5.zip
Initial addition of alpha3 release of e17
(Portage version: 2.2.0_alpha142-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'x11-wm/enlightenment')
-rw-r--r--x11-wm/enlightenment/ChangeLog8
-rw-r--r--x11-wm/enlightenment/enlightenment-0.17.0_alpha3.ebuild83
-rw-r--r--x11-wm/enlightenment/metadata.xml52
3 files changed, 142 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index 91e8703849cb..f9a7771e553b 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.157 2012/11/08 07:56:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.158 2012/11/16 20:11:28 tommy Exp $
+
+*enlightenment-0.17.0_alpha3 (16 Nov 2012)
+
+ 16 Nov 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +enlightenment-0.17.0_alpha3.ebuild, metadata.xml:
+ Initial addition of alpha3 release of e17
08 Nov 2012; Mike Frysinger <vapier@gentoo.org>
enlightenment-0.16.9999.ebuild:
diff --git a/x11-wm/enlightenment/enlightenment-0.17.0_alpha3.ebuild b/x11-wm/enlightenment/enlightenment-0.17.0_alpha3.ebuild
new file mode 100644
index 000000000000..1cf403cf1e62
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.17.0_alpha3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.17.0_alpha3.ebuild,v 1.1 2012/11/16 20:11:28 tommy Exp $
+
+EAPI="2"
+
+MY_P=${P/_alpha/-alpha}
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0.17"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@dialogs +@display +@edgebindings
+ +@interaction +@intl +@keybindings +@menus
+ +@paths +@performance +@randr +@shelves +@theme
+ +@wallpaper2 +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@backlight +@battery +@clock +@comp +@connman +@cpufreq +@dropshadow
+ +@everything +@fileman +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2
+ +@mixer +@msgbus +@notification +@pager +@quickaccess +@shot +@start
+ +@syscon +@systray +@tasks +@temperature +@tiling +@winlist +@wizard +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ >=dev-libs/efreet-1.7.1
+ >=dev-libs/eio-1.7.1
+ >=dev-libs/eina-1.7.1[mempool-chained]
+ || ( >=dev-libs/ecore-1.7.1[X,evas,inotify] >=dev-libs/ecore-1.7.1[xcb,evas,inotify] )
+ >=media-libs/edje-1.7.1
+ >=dev-libs/e_dbus-1.7.1[libnotify,udev?]
+ ukit? ( >=dev-libs/e_dbus-1.7.1[udev] )
+ enlightenment_modules_connman? ( >=dev-libs/e_dbus-1.7.1[connman] )
+ || ( >=media-libs/evas-1.7.1[eet,X,jpeg,png] >=media-libs/evas-1.7.1[eet,xcb,jpeg,png] )
+ >=dev-libs/eeze-1.7.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ export MY_ECONF="
+ --disable-install-sysactions
+ --disable-elementary
+ $(use_enable doc)
+ --disable-device-hal
+ --disable-mount-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ --disable-physics
+ "
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ MY_ECONF+=" $(use_enable ${u} ${c})"
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf || die
+}
diff --git a/x11-wm/enlightenment/metadata.xml b/x11-wm/enlightenment/metadata.xml
index c0e08e5919a4..0d9ea921c356 100644
--- a/x11-wm/enlightenment/metadata.xml
+++ b/x11-wm/enlightenment/metadata.xml
@@ -4,6 +4,10 @@
<maintainer>
<email>vapier@gentoo.org</email>
</maintainer>
+ <maintainer>
+ <email>enlightenment@gentoo.org</email>
+ <description>Maintainer for enlightenment:0.17</description>
+ </maintainer>
<longdescription>
Enlightenment is a completely themeable, highly configurable Window Manager for
the X Window System, traditionally used in Unix environments.
@@ -49,5 +53,53 @@ Enlightenment Features:
<use>
<flag name="pango">Enable pango font rendering</flag>
<flag name="xrandr">Enable support for the X xrandr extension</flag>
+ <flag name='udev'>Use sys-fs/udev to determine available devices</flag>
+ <flag name='ukit'>Use upower/udisks to automount devices</flag>
+ <flag name="enlightenment_modules_access">Accessibility module designed to improve ease of use for the vision impaired and the blind</flag>
+ <flag name="enlightenment_modules_backlight">Backlight control slider gadget</flag>
+ <flag name="enlightenment_modules_battery">A gadget to visualize your battery status</flag>
+ <flag name="enlightenment_modules_clock">Nice clock gadget to show current time</flag>
+ <flag name="enlightenment_modules_comp">Enlightenment Composite Manager</flag>
+ <flag name="enlightenment_modules_connman">Control Wifi and wired networks as a user</flag>
+ <flag name="enlightenment_modules_cpufreq">Gadget to monitor and change the CPU frequency</flag>
+ <flag name="enlightenment_modules_dropshadow">Module to add a dropshadow to windows</flag>
+ <flag name="enlightenment_modules_everything">The run command module provides an application launcher dialog</flag>
+ <flag name="enlightenment_modules_fileman">Enlightenment's integrated file manager</flag>
+ <flag name="enlightenment_modules_fileman-opinfo">Can be placed on the desktop or in a shelf</flag>
+ <flag name="enlightenment_modules_gadman">Module to manage gadgets on the desktop</flag>
+ <flag name="enlightenment_modules_ibar">Iconic application launcher</flag>
+ <flag name="enlightenment_modules_ibox">A home for your iconified applications</flag>
+ <flag name="enlightenment_modules_illume2">Illume2 - next generation of illume - special WM mode for embedded devices and set of plugins with same purpose</flag>
+ <flag name="enlightenment_modules_mixer">A module to provide a mixer for changing volume</flag>
+ <flag name="enlightenment_modules_msgbus">DBus Extension</flag>
+ <flag name="enlightenment_modules_notification">notification-daemon alternative. Popup if an event occur</flag>
+ <flag name="enlightenment_modules_pager">Gadget to allow you to visualize your virtual desktops and the windows they contain</flag>
+ <flag name="enlightenment_modules_quickaccess">Enlightenment Quickaccess Launcher</flag>
+ <flag name="enlightenment_modules_shot">Simple screenshot+save/upload module</flag>
+ <flag name="enlightenment_modules_start">Enlightenment's "Start" button equivalent</flag>
+ <flag name="enlightenment_modules_syscon">This module provides a unified popup dialog for all the system actions in Enlightenment</flag>
+ <flag name="enlightenment_modules_systray">system tray that hold applications icons like Skype, Pidgin, Kopete and others</flag>
+ <flag name="enlightenment_modules_tasks">Gadget to allow you to switch tasks</flag>
+ <flag name="enlightenment_modules_temperature">Temperature monitor</flag>
+ <flag name="enlightenment_modules_tiling">Positions/resizes your windows tilingly</flag>
+ <flag name="enlightenment_modules_winlist">A module to show the list of client applications presently running</flag>
+ <flag name="enlightenment_modules_wizard">First Run Wizard</flag>
+ <flag name="enlightenment_modules_xkbswitch">Keyboard layout configuration and switcher</flag>
+ <flag name="enlightenment_modules_conf-applications">Allows configuration of Ibar, Restart, and Startup applications</flag>
+ <flag name="enlightenment_modules_conf-dialogs">Configure default dialog properties</flag>
+ <flag name="enlightenment_modules_conf-display">Used to configure your screen</flag>
+ <flag name="enlightenment_modules_conf-edgebindings">Configure your edge bindings here</flag>
+ <flag name="enlightenment_modules_conf-interaction">Configure Mouse and Touch input</flag>
+ <flag name="enlightenment_modules_conf-intl">Used to select a default language</flag>
+ <flag name="enlightenment_modules_conf-keybindings">Key, Mouse and Button control settings</flag>
+ <flag name="enlightenment_modules_conf-menus">Configures menu behavior</flag>
+ <flag name="enlightenment_modules_conf-paths">Specifies the Enlightenment search paths and default directories</flag>
+ <flag name="enlightenment_modules_conf-performance">Used to configure certain performance related items as frame rates and cache settings</flag>
+ <flag name="enlightenment_modules_conf-randr">Used to configure your screen's resolution</flag>
+ <flag name="enlightenment_modules_conf-shelves">Shelf configuration dialog</flag>
+ <flag name="enlightenment_modules_conf-theme">Used to configure your theme preferences</flag>
+ <flag name="enlightenment_modules_conf-wallpaper2">Used to pick a wallpaper</flag>
+ <flag name="enlightenment_modules_conf-window-manipulation">Configures window raise, resistance, and maximize policies</flag>
+ <flag name="enlightenment_modules_conf-window-remembers">Delete existing window remembers</flag>
</use>
</pkgmetadata>