summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-02-26 16:10:56 +0000
committerMichael Weber <xmw@gentoo.org>2015-02-26 16:10:56 +0000
commit2cbf277a67b20e7bd0048eaa8fc9b4e15c5a4260 (patch)
treeeacb249bda77373271f28f116c0cad7204667f28 /x11-wm/cwm
parentdev-java/jflex: reverting back to old correct version of the 1.4.3 stable ebu... (diff)
downloadgentoo-2-2cbf277a67b20e7bd0048eaa8fc9b4e15c5a4260.tar.gz
gentoo-2-2cbf277a67b20e7bd0048eaa8fc9b4e15c5a4260.tar.bz2
gentoo-2-2cbf277a67b20e7bd0048eaa8fc9b4e15c5a4260.zip
Version bump (bug 538094).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-wm/cwm')
-rw-r--r--x11-wm/cwm/ChangeLog7
-rw-r--r--x11-wm/cwm/cwm-5.6.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-wm/cwm/ChangeLog b/x11-wm/cwm/ChangeLog
index 75e1b6ed284e..fad318ef73e4 100644
--- a/x11-wm/cwm/ChangeLog
+++ b/x11-wm/cwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/cwm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.47 2015/01/17 00:55:38 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.48 2015/02/26 16:10:56 xmw Exp $
+
+*cwm-5.6 (26 Feb 2015)
+
+ 26 Feb 2015; Michael Weber <xmw@gentoo.org> +cwm-5.6.ebuild:
+ Version bump (bug 538094).
17 Jan 2015; Michael Weber <xmw@gentoo.org> cwm-9999.ebuild:
add eutils.eclass for make_session_desktop
diff --git a/x11-wm/cwm/cwm-5.6.ebuild b/x11-wm/cwm/cwm-5.6.ebuild
new file mode 100644
index 000000000000..6abbe3ed20a3
--- /dev/null
+++ b/x11-wm/cwm/cwm-5.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-5.6.ebuild,v 1.1 2015/02/26 16:10:56 xmw Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ http://github.com/chneukirchen/cwm"
+SRC_URI="vanilla? ( http://chneukirchen.org/releases/${P}.tar.gz -> ${P}-chneukirchen.tar.gz )
+ !vanilla? ( https://github.com/xmw/cwm/tarball/ea9a436 -> ${P}-xmw.tar.gz )"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="vanilla"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison"
+
+src_unpack() {
+ default
+ # vcs-snapshot doesn't work with tarball names
+ if ! use vanilla ; then
+ mv *${PN}-* ${P} || die
+ fi
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}