summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-03-09 06:50:05 +0000
committerJoe McCann <joem@gentoo.org>2005-03-09 06:50:05 +0000
commit861d12b21c56aa2a79efce9ca195a29c1c5d1764 (patch)
tree534049e887e04c2112c17cb485ec6002716b0008 /x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild
parentAdd missing KEYWORDS. (diff)
downloadgentoo-2-861d12b21c56aa2a79efce9ca195a29c1c5d1764.tar.gz
gentoo-2-861d12b21c56aa2a79efce9ca195a29c1c5d1764.tar.bz2
gentoo-2-861d12b21c56aa2a79efce9ca195a29c1c5d1764.zip
gnome-2.10 release
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild')
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild
new file mode 100644
index 000000000000..ff9b107c228e
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.10.0.ebuild,v 1.1 2005/03/09 06:50:05 joem Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+IUSE=""
+
+RDEPEND="virtual/xft
+ >=x11-libs/gtk+-2.5.4
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-1.2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2.4
+ >=x11-libs/startup-notification-0.8
+ >=x11-libs/vte-0.11.10"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.3.11
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.29
+ !gnome-base/gnome-core"
+# gnome-core overwrite /usr/bin/gnome-terminal
+
+DOCS="AUTHORS ChangeLog README NEWS TODO"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # Use login shell by default (#12900)
+ epatch ${FILESDIR}/${PN}-2-default_shell.patch
+ # terminal enhancement, inserts a space after a DND URL
+ # patch by Zach Bagnall <yem@y3m.net> in #13801
+ epatch ${FILESDIR}/${PN}-2-dnd_url_add_space.patch
+
+}