summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-07-22 16:21:31 +0000
committerPeter Volkov <pva@gentoo.org>2010-07-22 16:21:31 +0000
commitd9cbc97d4506c959e944eafcc635b7f559e4bc5e (patch)
treed6be33cde163f16213983f824d05870cfc10da26 /x11-plugins
parentarm stable, bug #327777 (diff)
downloadgentoo-2-d9cbc97d4506c959e944eafcc635b7f559e4bc5e.tar.gz
gentoo-2-d9cbc97d4506c959e944eafcc635b7f559e4bc5e.tar.bz2
gentoo-2-d9cbc97d4506c959e944eafcc635b7f559e4bc5e.zip
Version bump, bug #326703, thank throw_away_2002@yahoo.com for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-encryption/ChangeLog7
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-encryption/ChangeLog b/x11-plugins/pidgin-encryption/ChangeLog
index 2a7afe94578f..c296f660fe8f 100644
--- a/x11-plugins/pidgin-encryption/ChangeLog
+++ b/x11-plugins/pidgin-encryption/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-encryption
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/ChangeLog,v 1.12 2010/07/08 19:23:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/ChangeLog,v 1.13 2010/07/22 16:21:31 pva Exp $
+
+*pidgin-encryption-3.1 (22 Jul 2010)
+
+ 22 Jul 2010; Peter Volkov <pva@gentoo.org> +pidgin-encryption-3.1.ebuild:
+ Version bump, bug #326703, thank throw_away_2002@yahoo.com for report.
08 Jul 2010; Raúl Porcel <armin76@gentoo.org>
pidgin-encryption-3.0-r1.ebuild:
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild
new file mode 100644
index 000000000000..47123354d8a5
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild,v 1.1 2010/07/22 16:21:31 pva Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Pidgin IM Encryption PlugIn"
+HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pidgin-encrypt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2
+ >=dev-libs/nss-3.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ strip-flags
+ replace-flags -O? -O2
+ econf $(use_enable nls)
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}