summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-31 14:25:01 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-31 14:25:01 +0000
commitafc48e0f573832ce9ab76c6db30f4657293fccfe (patch)
tree6cc7489350c70261253cdc4bf2bed044a0f8a7eb /x11-plugins
parentBuild with gcc47 (#424063 by Guillaume BINET) (diff)
downloadgentoo-2-afc48e0f573832ce9ab76c6db30f4657293fccfe.tar.gz
gentoo-2-afc48e0f573832ce9ab76c6db30f4657293fccfe.tar.bz2
gentoo-2-afc48e0f573832ce9ab76c6db30f4657293fccfe.zip
Fix gcc47 building (#424105) and respect LDFLAGS (#335391), also fix dependencies (#335391). Thanks to Michael Mair-Keimberger (iamnr3) for the work.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellmlaunch/ChangeLog8
-rw-r--r--x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch35
-rw-r--r--x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild22
3 files changed, 59 insertions, 6 deletions
diff --git a/x11-plugins/gkrellmlaunch/ChangeLog b/x11-plugins/gkrellmlaunch/ChangeLog
index 97faf0e57bc0..9f8bd72b010f 100644
--- a/x11-plugins/gkrellmlaunch/ChangeLog
+++ b/x11-plugins/gkrellmlaunch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gkrellmlaunch
# Copyright 2002-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmlaunch/ChangeLog,v 1.15 2013/06/01 11:35:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmlaunch/ChangeLog,v 1.16 2013/08/31 14:25:01 pacho Exp $
+
+ 31 Aug 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gkrellmlaunch-0.5-makefile.patch, gkrellmlaunch-0.5.ebuild:
+ Fix gcc47 building (#424105) and respect LDFLAGS (#335391), also fix
+ dependencies (#335391). Thanks to Michael Mair-Keimberger (iamnr3) for the
+ work.
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #144305
diff --git a/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch b/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch
new file mode 100644
index 000000000000..31175b664837
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch
@@ -0,0 +1,35 @@
+--- Makefile 2002-09-26 15:56:06.000000000 +0200
++++ Makefile_new 2013-03-15 17:26:19.398383410 +0100
+@@ -4,21 +4,25 @@
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) -g
++FLAGS = -fPIC $(GTK_INCLUDE)
+ #LIBS = $(GTK_LIB) $(IMLIB_LIB) -lefence
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+
+-LFLAGS = -shared -W1
++LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
++CC = $(CC)
+
+ OBJS = gkrellmlaunch.o
+
++all: gkrellmlaunch.so
++
++%.o: %.c
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
++
+ gkrellmlaunch.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellmlaunch.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) $(OBJS) -o gkrellmlaunch.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
+
+-gkrellmlaunch.o: gkrellmlaunch.c
+-
++gkrellmlaunch.o: gkrellmlaunch.c
+\ No newline at end of file
diff --git a/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild
index c6efaa569607..020920a375ab 100644
--- a/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild
+++ b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild
@@ -1,14 +1,26 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild,v 1.16 2007/07/11 20:39:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild,v 1.17 2013/08/31 14:25:01 pacho Exp $
-inherit gkrellm-plugin
+EAPI=5
+inherit eutils gkrellm-plugin toolchain-funcs
-IUSE=""
-DESCRIPTION="a Program-Launcher Plugin for GKrellM2"
+DESCRIPTION="A Program-Launcher Plugin for GKrellM2"
SRC_URI="mirror://sourceforge/gkrellmlaunch/${P}.tar.gz"
HOMEPAGE="http://gkrellmlaunch.sourceforge.net/"
+IUSE=""
SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc alpha amd64"
+
+RDEPEND="app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+} \ No newline at end of file