summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-03 21:24:43 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-03 21:24:43 +0000
commit9c738e36e0c335dfa230087c9650d745a0ebeae7 (patch)
tree3615b27aed0666587ddaa025c591a5f4e4c9886e /x11-plugins
parentlinux/uclibc/mips/make.defaults: add abi and libdir info, bug #479656 (diff)
downloadgentoo-2-9c738e36e0c335dfa230087c9650d745a0ebeae7.tar.gz
gentoo-2-9c738e36e0c335dfa230087c9650d745a0ebeae7.tar.bz2
gentoo-2-9c738e36e0c335dfa230087c9650d745a0ebeae7.zip
Version bump. Fixes bug #473872
(Portage version: 2.1.13.3/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-latex/ChangeLog10
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild46
2 files changed, 53 insertions, 3 deletions
diff --git a/x11-plugins/pidgin-latex/ChangeLog b/x11-plugins/pidgin-latex/ChangeLog
index 0a56a56f8318..a231fd0653df 100644
--- a/x11-plugins/pidgin-latex/ChangeLog
+++ b/x11-plugins/pidgin-latex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-latex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.26 2012/06/14 02:04:32 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.27 2013/08/03 21:24:43 mrueg Exp $
+
+*pidgin-latex-1.5.0 (03 Aug 2013)
+
+ 03 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +pidgin-latex-1.5.0.ebuild:
+ Version bump. Fixes bug #473872
14 Jun 2012; Michael Weber <xmw@gentoo.org> pidgin-latex-1.4.4.ebuild:
ppc stable (377911)
@@ -111,4 +116,3 @@
24 May 2007; Olivier Crête <tester@gentoo.org> +metadata.xml,
+pidgin-latex-1.0.ebuild:
Add pidgin-latex, which is the continuation of x11-plugins/gaim-latex
-
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild
new file mode 100644
index 000000000000..d739cd202def
--- /dev/null
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild,v 1.1 2013/08/03 21:24:43 mrueg Exp $
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Pidgin plugin that renders latex formulae"
+HOMEPAGE="http://sourceforge.net/projects/pidgin-latex/"
+SRC_URI="mirror://sourceforge/pidgin-latex/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/dvipng"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -e "s:\(CC.*=\).*:\1 $(tc-getCC):" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/pidgin:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc README CHANGELOG TODO
+}
+
+pkg_postinst() {
+ elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
+ elog 'switch off "ignore incoming format" option in plugin configuration.'
+ elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
+}