summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-04-01 15:22:06 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-04-01 15:22:06 +0000
commit949ae3f22f4150c412472660f4bfed2522762c95 (patch)
treec58287d29eaa25680517c22b3a88023549773faa /x11-plugins
parentVersion bump. (diff)
downloadgentoo-2-949ae3f22f4150c412472660f4bfed2522762c95.tar.gz
gentoo-2-949ae3f22f4150c412472660f4bfed2522762c95.tar.bz2
gentoo-2-949ae3f22f4150c412472660f4bfed2522762c95.zip
Fix compilation with format-security, bug #544644
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmswallow/ChangeLog6
-rw-r--r--x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch16
-rw-r--r--x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/x11-plugins/wmswallow/ChangeLog b/x11-plugins/wmswallow/ChangeLog
index eda75d50670b..efe2edc75fb1 100644
--- a/x11-plugins/wmswallow/ChangeLog
+++ b/x11-plugins/wmswallow/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmswallow
# Copyright 2000-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/ChangeLog,v 1.11 2015/03/27 16:28:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/ChangeLog,v 1.12 2015/04/01 15:22:06 voyageur Exp $
+
+ 01 Apr 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ wmswallow-0.6.1-r1.ebuild, +files/wmswallow-0.6.1-format-security.patch:
+ Fix compilation with format-security, bug #544644
27 Mar 2015; Agostino Sarubbo <ago@gentoo.org> wmswallow-0.6.1-r1.ebuild:
Stable for amd64, wrt bug #541774
diff --git a/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch b/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch
new file mode 100644
index 000000000000..7a2fe4cf1f36
--- /dev/null
+++ b/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch
@@ -0,0 +1,16 @@
+--- wmswallow.c.orig 2015-04-01 17:12:29.420177608 +0200
++++ wmswallow.c 2015-04-01 17:13:14.947182921 +0200
+@@ -445,11 +445,11 @@
+ int printlist(FILE * stream, char * string, char **stringlist) {
+ int i=0;
+
+- fprintf(stream, string);
++ fprintf(stream, "%s", string);
+ if (stringlist!=NULL) {
+ while (stringlist[i]!=NULL) {
+ fprintf(stream, " §");
+- fprintf(stream, stringlist[i]);
++ fprintf(stream, "%s", stringlist[i]);
+ fprintf(stream, "§ ");
+ ++i;
+ }
diff --git a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
index 5a50a0bfdf16..7a157c99b6e8 100644
--- a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
+++ b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild,v 1.2 2015/03/27 16:28:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild,v 1.3 2015/04/01 15:22:06 voyageur Exp $
EAPI=5
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="A dock applet to make any application dockable"
HOMEPAGE="http://burse.uni-hamburg.de/~friedel/software/wmswallow.html"
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/wmswallow
src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
-e "/LIBS/s/-lXext/-lX11 \0/"\
-i Makefile || die