summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-12 12:04:15 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-12 12:04:15 +0000
commit1efe5b8372ac053f34cca10e4608b23363913d04 (patch)
tree7875ec1bc12de4f21eeb1ad7a39fe39c7deb9861 /x11-plugins/wmtop/wmtop-0.9.0.ebuild
parentAdded pkgconfig dep to stable version also. (diff)
downloadgentoo-2-1efe5b8372ac053f34cca10e4608b23363913d04.tar.gz
gentoo-2-1efe5b8372ac053f34cca10e4608b23363913d04.tar.bz2
gentoo-2-1efe5b8372ac053f34cca10e4608b23363913d04.zip
Version bump wrt #203120 and mark it stable for amd64 because current stable does not meet required QA standards.
(Portage version: 2.1.4, RepoMan options: --force)
Diffstat (limited to 'x11-plugins/wmtop/wmtop-0.9.0.ebuild')
-rw-r--r--x11-plugins/wmtop/wmtop-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmtop/wmtop-0.9.0.ebuild b/x11-plugins/wmtop/wmtop-0.9.0.ebuild
new file mode 100644
index 000000000000..2d95fadc5c08
--- /dev/null
+++ b/x11-plugins/wmtop/wmtop-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/wmtop-0.9.0.ebuild,v 1.1 2008/01/12 12:04:14 drac Exp $
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="dockapp for monitoring the top three processes using cpu or memory."
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmtop"
+SRC_URI="http://www.swanson.ukfsn.org/wmdock/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPTS="${CFLAGS}" \
+ LIBDIR="-L/usr/$(get_libdir)" \
+ INCS="-I/usr/include/X11" linux || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc BUGS CHANGES README TODO
+}