summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-12-02 11:29:52 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-12-02 11:29:52 +0000
commit853d5f2618120871362e1be4d58e64698b86b11c (patch)
treec7faa832f3d0a29cbea700e33feb0fba52074db1 /x11-plugins/wmacpimon
parentVersion bump. Finally first stable release. (diff)
downloadgentoo-2-853d5f2618120871362e1be4d58e64698b86b11c.tar.gz
gentoo-2-853d5f2618120871362e1be4d58e64698b86b11c.tar.bz2
gentoo-2-853d5f2618120871362e1be4d58e64698b86b11c.zip
Fixed LDFLAGS ordering. See bug #248618.
(Portage version: 2.1.4.5)
Diffstat (limited to 'x11-plugins/wmacpimon')
-rw-r--r--x11-plugins/wmacpimon/ChangeLog7
-rw-r--r--x11-plugins/wmacpimon/files/Makefile.patch13
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild5
3 files changed, 22 insertions, 3 deletions
diff --git a/x11-plugins/wmacpimon/ChangeLog b/x11-plugins/wmacpimon/ChangeLog
index f2387f249473..155e6ffda20f 100644
--- a/x11-plugins/wmacpimon/ChangeLog
+++ b/x11-plugins/wmacpimon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmacpimon
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/ChangeLog,v 1.7 2007/07/22 05:29:57 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/ChangeLog,v 1.8 2008/12/02 11:29:52 s4t4n Exp $
+
+ 02 Dec 2008; Michele Noberasco <s4t4n@gentoo.org>; wmacpimon-0.2.1.ebuild, files/Makefile.patch:
+ Fixed LDFLAGS ordering. See bug #248618.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
wmacpimon-0.2.1.ebuild:
diff --git a/x11-plugins/wmacpimon/files/Makefile.patch b/x11-plugins/wmacpimon/files/Makefile.patch
new file mode 100644
index 000000000000..e4a759b83ebd
--- /dev/null
+++ b/x11-plugins/wmacpimon/files/Makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile 2002-11-26 22:53:07.000000000 +0100
++++ Makefile.new 2008-12-02 12:25:29.000000000 +0100
+@@ -11,8 +11,10 @@
+ all: wmacpimon wmacpimond
+
+ wmacpimon: $(OBJS)
++ $(CC) $(CFLAGS) -o wmacpimon $^ $(LDFLAGS)
+
+ wmacpimond: $(OBJZ)
++ $(CC) $(CFLAGS) -o wmacpimond $^ $(LDFLAGS)
+
+ clean:
+ rm -f *.o *~ wmacpimon wmacpimond trace *.out *.bb *.bbg
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
index c472e5606015..eb5a3f5a57cd 100644
--- a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.7 2008/06/29 13:12:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.8 2008/12/02 11:29:52 s4t4n Exp $
inherit eutils
@@ -27,6 +27,9 @@ src_unpack() {
# wmacpimon.prc to /var/tmp/
cd "${S}"
epatch "${FILESDIR}"/wmacpimon.c.patch
+
+ # fix LDFLAGS ordering. See bug #248618.
+ epatch "${FILESDIR}"/Makefile.patch
}
src_compile() {