summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-02-25 06:39:55 +0000
committerPeter Volkov <pva@gentoo.org>2010-02-25 06:39:55 +0000
commit23b7895426fa78035647fbb7270beef48ca66c36 (patch)
tree93093d674c24e1211c35152462ddbb8cc1264370 /x11-plugins/pidgin-latex
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-23b7895426fa78035647fbb7270beef48ca66c36.tar.gz
gentoo-2-23b7895426fa78035647fbb7270beef48ca66c36.tar.bz2
gentoo-2-23b7895426fa78035647fbb7270beef48ca66c36.zip
Version bump, bug #306191 thank ScytheMan for report.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-latex')
-rw-r--r--x11-plugins/pidgin-latex/ChangeLog8
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.3.2.ebuild42
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.3.4.ebuild49
3 files changed, 56 insertions, 43 deletions
diff --git a/x11-plugins/pidgin-latex/ChangeLog b/x11-plugins/pidgin-latex/ChangeLog
index 2911dadaa191..e03c672c03ff 100644
--- a/x11-plugins/pidgin-latex/ChangeLog
+++ b/x11-plugins/pidgin-latex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-latex
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.14 2010/01/08 09:16:47 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.15 2010/02/25 06:39:55 pva Exp $
+
+*pidgin-latex-1.3.4 (25 Feb 2010)
+
+ 25 Feb 2010; Peter Volkov <pva@gentoo.org> -pidgin-latex-1.3.2.ebuild,
+ +pidgin-latex-1.3.4.ebuild:
+ Version bump, bug #306191 thank ScytheMan for report.
08 Jan 2010; Peter Volkov <pva@gentoo.org> pidgin-latex-1.3.3.ebuild:
Added elog for possible cause why this plugin may not work.
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.3.2.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.3.2.ebuild
deleted file mode 100644
index c46e8975c4d7..000000000000
--- a/x11-plugins/pidgin-latex/pidgin-latex-1.3.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.3.2.ebuild,v 1.1 2009/08/22 04:35:30 tester Exp $
-
-inherit flag-o-matic multilib eutils
-
-DESCRIPTION="Pidgin plugin that renders latex formulae"
-HOMEPAGE="http://sourceforge.net/projects/pidgin-latex"
-SRC_URI="mirror://sourceforge/pidgin-latex/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="net-im/pidgin
- >=x11-libs/gtk+-2"
-RDEPEND="${DEPEND}
- app-text/dvipng
- media-gfx/imagemagick"
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
-src_compile()
-{
- append-flags -fPIC
- emake || die "emake failed"
-}
-
-src_install()
-{
- make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX="${D}/usr" \
- || die "make install failed"
- dodoc README CHANGELOG TODO
-}
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.3.4.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.3.4.ebuild
new file mode 100644
index 000000000000..a44fbdf69aa5
--- /dev/null
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.3.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.3.4.ebuild,v 1.1 2010/02/25 06:39:55 pva Exp $
+
+EAPI="2"
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Pidgin plugin that renders latex formulae"
+HOMEPAGE="http://sourceforge.net/projects/pidgin-latex"
+SRC_URI="mirror://sourceforge/pidgin-latex/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/libtool
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/dvipng"
+
+S=${WORKDIR}/${PN}
+
+src_prepare()
+{
+ sed -e "s:\(CC.*=\).*:\1 $(tc-getCC):" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/pidgin:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install()
+{
+ make PREFIX="${D}/usr" install || die "make install failed"
+ dodoc README CHANGELOG TODO || die
+}
+
+pkg_postinst() {
+ elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
+ elog 'switch off "ignore incoming format" option in plugin configuration.'
+ elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
+}