summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-12-31 16:12:31 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-12-31 16:12:31 +0000
commita60967e00d741d000b84e45a8b48d33b721aca73 (patch)
tree169907590a5a4e1490e9c7328836bbae00f43516 /x11-misc
parentFix bug 298547, and tidy up older versions. (diff)
downloadgentoo-2-a60967e00d741d000b84e45a8b48d33b721aca73.tar.gz
gentoo-2-a60967e00d741d000b84e45a8b48d33b721aca73.tar.bz2
gentoo-2-a60967e00d741d000b84e45a8b48d33b721aca73.zip
Version bump, bug fixes
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/gigolo/ChangeLog7
-rw-r--r--x11-misc/gigolo/gigolo-0.4.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-misc/gigolo/ChangeLog b/x11-misc/gigolo/ChangeLog
index 0d48885e5b57..f021fa0be8b5 100644
--- a/x11-misc/gigolo/ChangeLog
+++ b/x11-misc/gigolo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/gigolo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gigolo/ChangeLog,v 1.3 2009/08/23 03:30:32 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gigolo/ChangeLog,v 1.4 2009/12/31 16:12:31 darkside Exp $
+
+*gigolo-0.4.0 (31 Dec 2009)
+
+ 31 Dec 2009; Jeremy Olexa <darkside@gentoo.org> +gigolo-0.4.0.ebuild:
+ Version bump, bug fixes
23 Aug 2009; Jeremy Olexa <darkside@gentoo.org> gigolo-0.3.2.ebuild:
convert to EAPI-2, convert to xfconf.eclass
diff --git a/x11-misc/gigolo/gigolo-0.4.0.ebuild b/x11-misc/gigolo/gigolo-0.4.0.ebuild
new file mode 100644
index 000000000000..8a0d1b6f318c
--- /dev/null
+++ b/x11-misc/gigolo/gigolo-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gigolo/gigolo-0.4.0.ebuild,v 1.1 2009/12/31 16:12:31 darkside Exp $
+
+EAPI="2"
+inherit xfconf multilib
+
+DESCRIPTION="a frontend to easily manage connections to remote filesystems using
+GIO/GVfs"
+HOMEPAGE="http://www.uvena.de/gigolo/index.html http://goodies.xfce.org/projects/applications/gigolo"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.12:2
+ >=dev-libs/glib-2.16:2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_configure() {
+ ./waf --prefix="/usr" --libdir="/usr/$(get_libdir)" configure \
+ || die "./waf configure failed"
+}
+
+src_compile() {
+ # Build takes -jX, but not -lX so cannot use $MAKEOPTS
+ NUMJOBS=$(sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/; s/--jobs=\?/-j/' <<< ${MAKEOPTS})
+ ./waf build ${NUMJOBS} || die "./waf build failed"
+}
+
+src_install() {
+ ./waf --destdir="${D}" install || die "./waf install failed"
+
+ # process docs
+ dodoc ${DOCS} || die "dodoc failed"
+ rm -rf "${D}"/usr/share/doc/${PN}
+}