summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-22 07:07:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-22 07:07:35 +0000
commit6ede86ee1d4c3ca29e169d5f2064a68fe5aeb20e (patch)
tree6032640e1ab3a90082b3bb89f399dd518ec7a369 /x11-misc
parentInitial import of app-admin/haskell-updater (diff)
downloadgentoo-2-6ede86ee1d4c3ca29e169d5f2064a68fe5aeb20e.tar.gz
gentoo-2-6ede86ee1d4c3ca29e169d5f2064a68fe5aeb20e.tar.bz2
gentoo-2-6ede86ee1d4c3ca29e169d5f2064a68fe5aeb20e.zip
Send second argument (close) to libnotify for compability with 0.4.5.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfce4-notifyd/ChangeLog9
-rw-r--r--x11-misc/xfce4-notifyd/files/xfce4-notifyd-0.1.0-send-second-arg-notification-closed.patch32
-rw-r--r--x11-misc/xfce4-notifyd/xfce4-notifyd-0.1.0-r1.ebuild39
3 files changed, 79 insertions, 1 deletions
diff --git a/x11-misc/xfce4-notifyd/ChangeLog b/x11-misc/xfce4-notifyd/ChangeLog
index c3edcf8a19c2..9e3f48b3c28b 100644
--- a/x11-misc/xfce4-notifyd/ChangeLog
+++ b/x11-misc/xfce4-notifyd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xfce4-notifyd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfce4-notifyd/ChangeLog,v 1.3 2009/05/01 04:21:49 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfce4-notifyd/ChangeLog,v 1.4 2009/07/22 07:07:34 ssuominen Exp $
+
+*xfce4-notifyd-0.1.0-r1 (22 Jul 2009)
+
+ 22 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-notifyd-0.1.0-r1.ebuild,
+ +files/xfce4-notifyd-0.1.0-send-second-arg-notification-closed.patch:
+ Send second argument (close) to libnotify for compability with 0.4.5.
01 May 2009; Jeremy Olexa <darkside@gentoo.org>
xfce4-notifyd-0.1.0.ebuild:
diff --git a/x11-misc/xfce4-notifyd/files/xfce4-notifyd-0.1.0-send-second-arg-notification-closed.patch b/x11-misc/xfce4-notifyd/files/xfce4-notifyd-0.1.0-send-second-arg-notification-closed.patch
new file mode 100644
index 000000000000..72e15cfb8e2a
--- /dev/null
+++ b/x11-misc/xfce4-notifyd/files/xfce4-notifyd-0.1.0-send-second-arg-notification-closed.patch
@@ -0,0 +1,32 @@
+Snatched from Debian for compability with libnotify 0.4.5.
+
+diff -ur xfce4-notifyd-0.1.0.orig/xfce4-notifyd/xfce-notify-daemon.c xfce4-notifyd-0.1.0/xfce4-notifyd/xfce-notify-daemon.c
+--- xfce4-notifyd-0.1.0.orig/xfce4-notifyd/xfce-notify-daemon.c 2008-09-21 10:28:50.000000000 +0300
++++ xfce4-notifyd-0.1.0/xfce4-notifyd/xfce-notify-daemon.c 2009-07-22 10:02:12.000000000 +0300
+@@ -125,15 +125,10 @@
+ G_SIGNAL_RUN_LAST,
+ 0,
+ NULL, NULL,
+- g_cclosure_marshal_VOID__UINT,
+- G_TYPE_NONE, 1,
+- G_TYPE_UINT);
+-#if 0 /* it seems libnotify doesn't support the close-reason arg */
+ xfce_notify_marshal_VOID__UINT_UINT,
+ G_TYPE_NONE, 2,
+ G_TYPE_UINT,
+ G_TYPE_UINT);
+-#endif
+ signals[SIG_ACTION_INVOKED] = g_signal_new("action-invoked",
+ XFCE_TYPE_NOTIFY_DAEMON,
+ G_SIGNAL_RUN_LAST,
+@@ -215,9 +210,7 @@
+
+ g_tree_remove(daemon->active_notifications, id_p);
+ g_signal_emit(G_OBJECT(daemon), signals[SIG_NOTIFICATION_CLOSED], 0,
+- GPOINTER_TO_UINT(id_p));
+- /* NOTE: libnotify doesn't support the close-reason argument to
+- * the signal. not sure why. */
++ GPOINTER_TO_UINT(id_p), reason);
+ }
+
+ static void
diff --git a/x11-misc/xfce4-notifyd/xfce4-notifyd-0.1.0-r1.ebuild b/x11-misc/xfce4-notifyd/xfce4-notifyd-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..7c94042a58a6
--- /dev/null
+++ b/x11-misc/xfce4-notifyd/xfce4-notifyd-0.1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfce4-notifyd/xfce4-notifyd-0.1.0-r1.ebuild,v 1.1 2009/07/22 07:07:34 ssuominen Exp $
+
+EAPI=1
+inherit eutils xfce4
+
+XFCE_VERSION=4.6
+
+DESCRIPTION="Xfce4 notification daemon"
+HOMEPAGE="http://spuriousinterrupt.org/projects/xfce4-notifyd"
+SRC_URI="http://spuriousinterrupt.org/files/${PN}/${P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libsexy"
+
+RDEPEND="dev-libs/dbus-glib
+ gnome-base/libglade
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_VERSION}
+ >=xfce-base/xfconf-${XFCE_VERSION}
+ libsexy? ( x11-libs/libsexy )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ !<x11-libs/libnotify-0.4.5
+ !x11-misc/notification-daemon
+ !xfce-extra/notification-daemon-xfce"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ XFCE_CONFIG=" $(use_enable libsexy) --enable-maintainer-mode"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-send-second-arg-notification-closed.patch
+}