summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-27 23:31:11 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-27 23:31:11 +0000
commit0d323494cfda7fd82d2e52d90d013344cff6df24 (patch)
treea3ff7b03c5f69c8cb1e9c2d469cdf099226ad638 /x11-misc/xplanet
parentkde_sandbox_patch() typo fix (diff)
downloadgentoo-2-0d323494cfda7fd82d2e52d90d013344cff6df24.tar.gz
gentoo-2-0d323494cfda7fd82d2e52d90d013344cff6df24.tar.bz2
gentoo-2-0d323494cfda7fd82d2e52d90d013344cff6df24.zip
man page/LFH fix
Diffstat (limited to 'x11-misc/xplanet')
-rw-r--r--x11-misc/xplanet/files/digest-xplanet-0.93-r11
-rw-r--r--x11-misc/xplanet/xplanet-0.93-r1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xplanet/files/digest-xplanet-0.93-r1 b/x11-misc/xplanet/files/digest-xplanet-0.93-r1
new file mode 100644
index 000000000000..98ae5af16ac5
--- /dev/null
+++ b/x11-misc/xplanet/files/digest-xplanet-0.93-r1
@@ -0,0 +1 @@
+MD5 e3f8cbcc5dae1c53119b0947f7ff20ae xplanet-0.93.tar.gz 1164083
diff --git a/x11-misc/xplanet/xplanet-0.93-r1.ebuild b/x11-misc/xplanet/xplanet-0.93-r1.ebuild
new file mode 100644
index 000000000000..a3f73e3a012f
--- /dev/null
+++ b/x11-misc/xplanet/xplanet-0.93-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Kalen Petersen <kalenp@cs.washington.edu>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-0.93-r1.ebuild,v 1.1 2002/03/27 23:31:11 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A program to render images of the earth into the X root window"
+SRC_URI="http://prdownloads.sourceforge.net/xplanet/${P}.tar.gz"
+HOMEPAGE="http://xplanet.sourceforge.net/"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ local myconf
+ if [ "`use opengl`" ]
+ then
+ myconf="--with-gl --with-glut --with-animation"
+ else
+ myconf="--with-gl=no --with-glut=no --with-animation=no"
+ fi
+ if [ "`use gif`" ]
+ then
+ myconf="$myconf --with-gif"
+ else
+ myconf="$myconf --with-gif=no"
+ fi
+ if [ "`use X`" ]
+ then
+ myconf="$myconf --with-x"
+ else
+ myconf="$myconf --with-x=no"
+ fi
+
+ ./configure --prefix=/usr \
+ --with-freetype=no \
+ --mandir=/usr/share/man \
+ $myconf || die
+ # xplanet doesn't like to build parallel
+ # This fix taken from the gimp ebuild
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+}
+