summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-11 12:18:53 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-11 12:18:53 +0000
commit2f23d0be4a5bdad16f208fe17f1e867b9e715d9f (patch)
tree12e863888c93e01c1e47071fb888f9ef33607a34 /x11-misc/xosview
parentfix comments (diff)
downloadgentoo-2-2f23d0be4a5bdad16f208fe17f1e867b9e715d9f.tar.gz
gentoo-2-2f23d0be4a5bdad16f208fe17f1e867b9e715d9f.tar.bz2
gentoo-2-2f23d0be4a5bdad16f208fe17f1e867b9e715d9f.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xosview')
-rw-r--r--x11-misc/xosview/ChangeLog7
-rw-r--r--x11-misc/xosview/xosview-1.13.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/xosview/ChangeLog b/x11-misc/xosview/ChangeLog
index 745fb8897c73..df7020da4428 100644
--- a/x11-misc/xosview/ChangeLog
+++ b/x11-misc/xosview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xosview
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.69 2013/02/17 16:58:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.70 2013/03/11 12:18:53 jer Exp $
+
+*xosview-1.13 (11 Mar 2013)
+
+ 11 Mar 2013; Jeroen Roovers <jer@gentoo.org> +xosview-1.13.ebuild:
+ Version bump.
17 Feb 2013; Jeroen Roovers <jer@gentoo.org> -xosview-1.11.ebuild,
-xosview-1.9.4.ebuild:
diff --git a/x11-misc/xosview/xosview-1.13.ebuild b/x11-misc/xosview/xosview-1.13.ebuild
new file mode 100644
index 000000000000..77125e566dd3
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/xosview-1.13.ebuild,v 1.1 2013/03/11 12:18:53 jer Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -e 's:lib/X11/app:share/X11/app:g' \
+ -i xosview.1 || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+ doman *.1
+ dodoc CHANGES README.linux TODO
+}
+
+pkg_postinst() {
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}