summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-28 20:04:24 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-28 20:04:24 +0000
commitf1ae6ac54ba587173101f6bef77f25beadc137a5 (patch)
tree57c15006b1d9148f9540a8219b4e47d9213bb46f /x11-misc/xfe/xfe-0.84.ebuild
parentVersion bump. 0.2.4 stable on x86. (diff)
downloadgentoo-2-f1ae6ac54ba587173101f6bef77f25beadc137a5.tar.gz
gentoo-2-f1ae6ac54ba587173101f6bef77f25beadc137a5.tar.bz2
gentoo-2-f1ae6ac54ba587173101f6bef77f25beadc137a5.zip
Add patch to fix compilation with gcc-4 by Brian Merrill <bmerrill AT sfcn DOT org>; bug #111321
(Portage version: 2.1_pre2)
Diffstat (limited to 'x11-misc/xfe/xfe-0.84.ebuild')
-rw-r--r--x11-misc/xfe/xfe-0.84.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-misc/xfe/xfe-0.84.ebuild b/x11-misc/xfe/xfe-0.84.ebuild
index d881e0b63d7b..4e6b7344ac4a 100644
--- a/x11-misc/xfe/xfe-0.84.ebuild
+++ b/x11-misc/xfe/xfe-0.84.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.84.ebuild,v 1.1 2005/07/05 21:55:45 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.84.ebuild,v 1.2 2005/12/28 20:04:24 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="MS-Explorer-like minimalist file manager for X"
HOMEPAGE="http://roland65.free.fr/xfe/"
@@ -15,6 +17,13 @@ IUSE="nls"
DEPEND="virtual/x11
=x11-libs/fox-1.4*"
+src_unpack()
+{
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile()
{
econf $(use_enable nls) || die "econf failed"