summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-12-09 17:41:33 +0000
committerJeroen Roovers <jer@gentoo.org>2010-12-09 17:41:33 +0000
commitb837f177bf8bef44b3a1390195b7b14adde1fd94 (patch)
tree56baaf9dffbc1b43515882598cbecbfc98c6a3c9 /x11-misc/xbindkeys
parentVersion bump wrt #348286 by Christian Faulhammer. (diff)
downloadgentoo-2-b837f177bf8bef44b3a1390195b7b14adde1fd94.tar.gz
gentoo-2-b837f177bf8bef44b3a1390195b7b14adde1fd94.tar.bz2
gentoo-2-b837f177bf8bef44b3a1390195b7b14adde1fd94.zip
Version bump by ashtophet (bug #348251).
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'x11-misc/xbindkeys')
-rw-r--r--x11-misc/xbindkeys/ChangeLog7
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-misc/xbindkeys/ChangeLog b/x11-misc/xbindkeys/ChangeLog
index 679a8696a372..bc7e37d03215 100644
--- a/x11-misc/xbindkeys/ChangeLog
+++ b/x11-misc/xbindkeys/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xbindkeys
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.52 2010/02/08 18:20:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.53 2010/12/09 17:41:33 jer Exp $
+
+*xbindkeys-1.8.4 (09 Dec 2010)
+
+ 09 Dec 2010; Jeroen Roovers <jer@gentoo.org> +xbindkeys-1.8.4.ebuild:
+ Version bump by ashtophet (bug #348251).
08 Feb 2010; Jeroen Roovers <jer@gentoo.org> xbindkeys-1.7.3.ebuild,
xbindkeys-1.8.0.ebuild, xbindkeys-1.8.3.ebuild:
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.4.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.4.ebuild
new file mode 100644
index 000000000000..997ea92fd4cd
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.4.ebuild,v 1.1 2010/12/09 17:41:33 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="guile tk"
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="http://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+RDEPEND="x11-libs/libX11
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
+ tk? ( dev-lang/tk )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_configure() {
+ local myconf
+ use tk || myconf="${myconf} --disable-tk"
+ use guile || myconf="${myconf} --disable-guile"
+
+ econf ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake DESTDIR="${D}" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" BINDIR=/usr/bin install || die "make install failed"
+}