summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-14 06:59:59 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-14 06:59:59 +0000
commit89bc82ddde74d6fb684152ce4bf345363f5cf4d2 (patch)
tree938ec12f22dd15812506006b2de25bce283845b5 /x11-misc/touchcal
parentFix for _FORTIFY_SOURCE indicates presence of overflow, #363543 (diff)
downloadgentoo-2-89bc82ddde74d6fb684152ce4bf345363f5cf4d2.tar.gz
gentoo-2-89bc82ddde74d6fb684152ce4bf345363f5cf4d2.tar.bz2
gentoo-2-89bc82ddde74d6fb684152ce4bf345363f5cf4d2.zip
Version Bump, backport change for bufferoverflow
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/touchcal')
-rw-r--r--x11-misc/touchcal/ChangeLog8
-rw-r--r--x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch24
-rw-r--r--x11-misc/touchcal/touchcal-0.40.ebuild17
3 files changed, 37 insertions, 12 deletions
diff --git a/x11-misc/touchcal/ChangeLog b/x11-misc/touchcal/ChangeLog
index b97146f658e7..c186c39d78d5 100644
--- a/x11-misc/touchcal/ChangeLog
+++ b/x11-misc/touchcal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/touchcal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/ChangeLog,v 1.7 2011/04/14 06:56:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/ChangeLog,v 1.8 2011/04/14 06:59:59 jlec Exp $
+
+*touchcal-0.40 (14 Apr 2011)
+
+ 14 Apr 2011; Justin Lecher <jlec@gentoo.org>
+ files/touchcal-0.31-buff-overflow.patch, +touchcal-0.40.ebuild:
+ Version Bump, backport change for bufferoverflow
*touchcal-0.31-r1 (14 Apr 2011)
diff --git a/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch b/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch
index 7c64d5c4c7ee..a9bea151f8e6 100644
--- a/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch
+++ b/x11-misc/touchcal/files/touchcal-0.31-buff-overflow.patch
@@ -1,16 +1,18 @@
- touchcal.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
+ touchcal.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/touchcal.c b/touchcal.c
-index 7341fd7..22bd978 100644
+index 7341fd7..93b262c 100644
--- a/touchcal.c
+++ b/touchcal.c
-@@ -96,7 +96,7 @@ static void init_mu(char dev[])
- char buf[255],dummy[255];
- char format_tablet[4],get_page[5],set_page[5],mode_stream[4];
- char reset_controler[3],identify[4];
-- char data[16];
-+ char data[26];
+@@ -138,8 +138,8 @@ static void init_mu(char dev[])
+ set_page[3]='1';
+ set_page[4]=0x0d;
+
+- /*define data string*/
+- strcpy(data,"00180769001D0793");
++ /* define data string */
++ strncpy(data, "00180769001D0793", 16);
+
+ bzero(&newtio, sizeof(newtio)); /* clear struct for new port settings */
- /*Open serial device for reading and writing*/
- fd = open(dev, O_RDWR | O_NOCTTY );
diff --git a/x11-misc/touchcal/touchcal-0.40.ebuild b/x11-misc/touchcal/touchcal-0.40.ebuild
new file mode 100644
index 000000000000..926843edc247
--- /dev/null
+++ b/x11-misc/touchcal/touchcal-0.40.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/touchcal/touchcal-0.40.ebuild,v 1.1 2011/04/14 06:59:59 jlec Exp $
+
+EAPI="4"
+
+DESCRIPTION="Touchscreen calibration utility"
+HOMEPAGE="http://touchcal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"