summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 10:48:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 10:48:18 +0000
commit985a2b81f0a0a6bbe85bc518f1d4a5571abeeac2 (patch)
tree6b29919de6e16e409dd47240b812b1ce6eac116d /x11-misc/notification-daemon
parentAlso fix pax stuff and bump EAPI in older ebuild (diff)
downloadgentoo-2-985a2b81f0a0a6bbe85bc518f1d4a5571abeeac2.tar.gz
gentoo-2-985a2b81f0a0a6bbe85bc518f1d4a5571abeeac2.tar.bz2
gentoo-2-985a2b81f0a0a6bbe85bc518f1d4a5571abeeac2.zip
Fix compability with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/notification-daemon')
-rw-r--r--x11-misc/notification-daemon/ChangeLog7
-rw-r--r--x11-misc/notification-daemon/files/notification-daemon-0.5.0-libnotify-0.7.patch29
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild18
3 files changed, 46 insertions, 8 deletions
diff --git a/x11-misc/notification-daemon/ChangeLog b/x11-misc/notification-daemon/ChangeLog
index c35f50c42b2a..929b53c4442a 100644
--- a/x11-misc/notification-daemon/ChangeLog
+++ b/x11-misc/notification-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/notification-daemon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.72 2011/01/24 23:22:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.73 2011/02/05 10:48:18 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ notification-daemon-0.5.0.ebuild,
+ +files/notification-daemon-0.5.0-libnotify-0.7.patch:
+ Fix compability with x11-libs/libnotify >= 0.7.
*notification-daemon-0.5.0 (24 Jan 2011)
diff --git a/x11-misc/notification-daemon/files/notification-daemon-0.5.0-libnotify-0.7.patch b/x11-misc/notification-daemon/files/notification-daemon-0.5.0-libnotify-0.7.patch
new file mode 100644
index 000000000000..fb457d498194
--- /dev/null
+++ b/x11-misc/notification-daemon/files/notification-daemon-0.5.0-libnotify-0.7.patch
@@ -0,0 +1,29 @@
+diff -ur notification-daemon-0.5.0.orig/src/capplet/notification-properties.c notification-daemon-0.5.0/src/capplet/notification-properties.c
+--- notification-daemon-0.5.0.orig/src/capplet/notification-properties.c 2010-05-28 17:41:17.000000000 +0300
++++ notification-daemon-0.5.0/src/capplet/notification-properties.c 2011-02-05 12:47:22.000000000 +0200
+@@ -27,6 +27,10 @@
+ #include <string.h>
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "stack.h"
+
+ #define GCONF_KEY_DAEMON "/apps/notification-daemon"
+@@ -402,8 +406,12 @@
+
+ dialog->preview = notify_notification_new (_("Notification Test"),
+ _("Just a test"),
+- "gnome-util",
+- NULL);
++ "gnome-util"
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+
+ if (!notify_notification_show (dialog->preview, &error)) {
+ char *message;
diff --git a/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild b/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
index b5d8d27a216d..efeb8cfbd147 100644
--- a/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
+++ b/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild,v 1.1 2011/01/24 23:22:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild,v 1.2 2011/02/05 10:48:18 ssuominen Exp $
-EAPI="3"
-GCONF_DEBUG="no"
+EAPI=3
+GCONF_DEBUG=no
+inherit eutils gnome2
-inherit gnome2
-
-DESCRIPTION="Notifications daemon"
+DESCRIPTION="Notification daemon"
HOMEPAGE="http://www.galago-project.org/"
LICENSE="GPL-2"
@@ -35,7 +34,12 @@ pkg_setup() {
G2CONF="${G2CONF} --disable-static"
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install
- find "${ED}" -name "*.la" -delete || die "la files removal failed"
+ find "${ED}" -name "*.la" -delete
}