summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-02-25 16:28:19 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-02-25 16:28:19 +0000
commitd9c479b80543dd39bb243c4a39675af44d60076a (patch)
tree52774d7c607c71e12bc60e126f07d74dbf4249a2 /x11-misc/menumaker
parentppc stable, bug #259578 (diff)
downloadgentoo-2-d9c479b80543dd39bb243c4a39675af44d60076a.tar.gz
gentoo-2-d9c479b80543dd39bb243c4a39675af44d60076a.tar.bz2
gentoo-2-d9c479b80543dd39bb243c4a39675af44d60076a.zip
Version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'x11-misc/menumaker')
-rw-r--r--x11-misc/menumaker/ChangeLog9
-rw-r--r--x11-misc/menumaker/menumaker-0.99.7.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/x11-misc/menumaker/ChangeLog b/x11-misc/menumaker/ChangeLog
index 989da1fd798d..e3064d792189 100644
--- a/x11-misc/menumaker/ChangeLog
+++ b/x11-misc/menumaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/menumaker
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/menumaker/ChangeLog,v 1.6 2008/09/17 21:27:57 coldwind Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/menumaker/ChangeLog,v 1.7 2009/02/25 16:28:19 neurogeek Exp $
+
+*menumaker-0.99.7 (25 Feb 2009)
+
+ 25 Feb 2009; <neurogeek@gentoo.org> +menumaker-0.99.7.ebuild:
+ Version bump
17 Sep 2008; Santiago M. Mola <coldwind@gentoo.org>
-menumaker-0.15.ebuild, menumaker-0.17.ebuild:
diff --git a/x11-misc/menumaker/menumaker-0.99.7.ebuild b/x11-misc/menumaker/menumaker-0.99.7.ebuild
new file mode 100644
index 000000000000..76e89b8318e6
--- /dev/null
+++ b/x11-misc/menumaker/menumaker-0.99.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/menumaker/menumaker-0.99.7.ebuild,v 1.1 2009/02/25 16:28:19 neurogeek Exp $
+
+inherit autotools
+
+DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
+HOMEPAGE="http://menumaker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="virtual/python
+ doc? ( sys-apps/texinfo )"
+MAKEOPTS="-j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf
+ emake || die "emake failed"
+
+ if use doc; then
+ cd "${S}/doc" && make html || die "Could not build docs"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README NEWS AUTHORS INSTALL
+
+ if use doc; then
+ dohtml "${S}"/doc/mmaker.html/*
+ fi
+
+}