summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2010-01-20 22:30:23 +0000
committerSven Wegener <swegener@gentoo.org>2010-01-20 22:30:23 +0000
commita0f326589d2214a18debaae46b83f20fb83a0a21 (patch)
tree9d5cfb5a087b495f5496fe2671ea35b20aa2db82 /x11-misc/glipper/glipper-1.0-r3.ebuild
parentFix configure loop, bug #297482. Fix localstatedir for init script. (diff)
downloadgentoo-2-a0f326589d2214a18debaae46b83f20fb83a0a21.tar.gz
gentoo-2-a0f326589d2214a18debaae46b83f20fb83a0a21.tar.bz2
gentoo-2-a0f326589d2214a18debaae46b83f20fb83a0a21.zip
Revision bump. Fix bad pkg-config file, bug #294182. Restrict test, bug #294565.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/glipper/glipper-1.0-r3.ebuild')
-rw-r--r--x11-misc/glipper/glipper-1.0-r3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/glipper/glipper-1.0-r3.ebuild b/x11-misc/glipper/glipper-1.0-r3.ebuild
new file mode 100644
index 000000000000..c8a84333eab0
--- /dev/null
+++ b/x11-misc/glipper/glipper-1.0-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/glipper/glipper-1.0-r3.ebuild,v 1.1 2010/01/20 22:30:23 swegener Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 python eutils multilib
+
+DESCRIPTION="GNOME Clipboard Manager"
+HOMEPAGE="http://glipper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/pygobject-2.6
+ >=dev-python/pygtk-2.6
+ >=dev-python/gconf-python-2.22.0
+ >=dev-python/libgnome-python-2.22.0
+ >=dev-python/gnome-applets-python-2.22.0
+ >=dev-python/gnome-vfs-python-2.22.0
+ >=gnome-base/gnome-desktop-2.10"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_unpack() {
+ gnome2_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-binary-data.patch
+ epatch "${FILESDIR}"/${P}-transparent.patch
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+}
+
+src_install() {
+ gnome2_src_install py_compile=true
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/glipper
+
+ elog "Glipper has been completely rewritten as a panel applet. Please remove your"
+ elog "existing ~/.glipper directory and then add glipper as a new panel applet."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup
+}