summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-21 12:07:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-21 12:07:23 +0000
commita48f3f76be0546039e66beb3a0b1745cdb5ad809 (patch)
treedb6d1c54ace7326071664565621ac812003d62e4 /x11-misc/devilspie2
parentVersion bump. (diff)
downloadgentoo-2-a48f3f76be0546039e66beb3a0b1745cdb5ad809.tar.gz
gentoo-2-a48f3f76be0546039e66beb3a0b1745cdb5ad809.tar.bz2
gentoo-2-a48f3f76be0546039e66beb3a0b1745cdb5ad809.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/ChangeLog7
-rw-r--r--x11-misc/devilspie2/devilspie2-0.30.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-misc/devilspie2/ChangeLog b/x11-misc/devilspie2/ChangeLog
index 61d2a40b584e..d3c42b7dea67 100644
--- a/x11-misc/devilspie2/ChangeLog
+++ b/x11-misc/devilspie2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/devilspie2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.6 2013/06/25 13:00:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.7 2013/07/21 12:07:23 hasufell Exp $
+
+*devilspie2-0.30 (21 Jul 2013)
+
+ 21 Jul 2013; Julian Ospald <hasufell@gentoo.org> +devilspie2-0.30.ebuild:
+ version bump
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> devilspie2-0.29.ebuild:
Stable for amd64, wrt bug #474392
diff --git a/x11-misc/devilspie2/devilspie2-0.30.ebuild b/x11-misc/devilspie2/devilspie2-0.30.ebuild
new file mode 100644
index 000000000000..8c198f4a033f
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.30.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/devilspie2-0.30.ebuild,v 1.1 2013/07/21 12:07:23 hasufell Exp $
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="sv fr pt_BR nl ru fi"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default folder for scripts is ~/.config/devilspie2/"
+}