summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-07 17:19:36 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-07 17:19:36 +0000
commit6e6dcd71ccd7d78dd6cf95c9403010206387fc04 (patch)
tree9d5179708a742e2e727243d0d8244e7972ae596c /x11-misc/accessx
parentMarked ~hppa (LuckyLuke in #gentoo-hppa). (diff)
downloadgentoo-2-6e6dcd71ccd7d78dd6cf95c9403010206387fc04.tar.gz
gentoo-2-6e6dcd71ccd7d78dd6cf95c9403010206387fc04.tar.bz2
gentoo-2-6e6dcd71ccd7d78dd6cf95c9403010206387fc04.zip
Fix building with a patchset from FreeBSD and keyword ~amd64 wrt #196764, thanks to Martic Berkemeier for reporting. Also respect correct CXX and CXXFLAGS targets and sanitize ebuild.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'x11-misc/accessx')
-rw-r--r--x11-misc/accessx/ChangeLog12
-rw-r--r--x11-misc/accessx/accessx-0951-r1.ebuild37
-rw-r--r--x11-misc/accessx/files/access-gcc3-gentoo.patch12
-rw-r--r--x11-misc/accessx/files/accessx-0951-build.patch65
-rw-r--r--x11-misc/accessx/files/digest-accessx-0951-r13
5 files changed, 115 insertions, 14 deletions
diff --git a/x11-misc/accessx/ChangeLog b/x11-misc/accessx/ChangeLog
index 6f61ee2cf641..c43d17092d19 100644
--- a/x11-misc/accessx/ChangeLog
+++ b/x11-misc/accessx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/accessx
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/accessx/ChangeLog,v 1.21 2007/07/22 02:43:59 coldwind Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/accessx/ChangeLog,v 1.22 2008/01/07 17:19:35 drac Exp $
+
+*accessx-0951-r1 (07 Jan 2008)
+
+ 07 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/accessx-0951-build.patch, +accessx-0951-r1.ebuild:
+ Fix building with a patchset from FreeBSD and keyword ~amd64 wrt #196764,
+ thanks to Martic Berkemeier for reporting. Also respect correct CXX and
+ CXXFLAGS targets and sanitize ebuild.
22 Jul 2007; Santiago M. Mola <coldwind@gentoo.org> accessx-0951.ebuild:
virtual/x11 removed and clean up.
diff --git a/x11-misc/accessx/accessx-0951-r1.ebuild b/x11-misc/accessx/accessx-0951-r1.ebuild
new file mode 100644
index 000000000000..09ee4a3664ca
--- /dev/null
+++ b/x11-misc/accessx/accessx-0951-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/accessx/accessx-0951-r1.ebuild,v 1.1 2008/01/07 17:19:35 drac Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Interface to the XKEYBOARD extension in X11"
+HOMEPAGE="http://cmos-eng.rehab.uiuc.edu/accessx"
+SRC_URI="http://cmos-eng.rehab.uiuc.edu/${PN}/software/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ dev-lang/tk"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" OPTS="${CXXFLAGS}" \
+ XLIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
+}
+
+src_install() {
+ dobin accessx ax
+ dodoc CHANGES README
+}
diff --git a/x11-misc/accessx/files/access-gcc3-gentoo.patch b/x11-misc/accessx/files/access-gcc3-gentoo.patch
deleted file mode 100644
index 49e8c9132622..000000000000
--- a/x11-misc/accessx/files/access-gcc3-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur accessx/ax.C accessx.m/ax.C
---- accessx/ax.C 2001-03-13 23:42:10.000000000 -0600
-+++ accessx.m/ax.C 2002-07-24 22:15:20.000000000 -0500
-@@ -713,7 +713,7 @@
- ///////////////////////////////////////////////////////////////////////////////
-
-
--void main(int argc, char** argv)
-+int main(int argc, char** argv)
- {
- Access ax;
- ax.QueryServer();
diff --git a/x11-misc/accessx/files/accessx-0951-build.patch b/x11-misc/accessx/files/accessx-0951-build.patch
new file mode 100644
index 000000000000..6d732487214f
--- /dev/null
+++ b/x11-misc/accessx/files/accessx-0951-build.patch
@@ -0,0 +1,65 @@
+diff -ur accessx.orig/Access.C accessx/Access.C
+--- accessx.orig/Access.C 2003-09-19 19:08:01.000000000 +0300
++++ accessx/Access.C 2008-01-07 18:53:43.000000000 +0200
+@@ -22,6 +22,8 @@
+ #include <X11/XKBlib.h>
+ #include "Access.h"
+
++using namespace std;
++
+ //
+ // Access()
+ //
+@@ -153,7 +155,7 @@
+ //Get the state of the keyboard.
+
+ XkbDescPtr xkb = XkbGetMap(display, 0, XkbUseCoreKbd);
+- if ((int)xkb == BadAlloc || xkb == NULL)
++ if (xkb == NULL)
+ {
+ return 5; /*AccessKeyboardQueryFailure;*/
+ }
+@@ -262,7 +264,7 @@
+ //Get the state of the keyboard.
+
+ XkbDescPtr xkb = XkbGetMap(display, 0, XkbUseCoreKbd);
+- if ((int)xkb == BadAlloc || xkb == NULL)
++ if (xkb == NULL)
+ {
+ return 5; /*AccessKeyboardQueryFailure;*/
+ }
+diff -ur accessx.orig/Access.h accessx/Access.h
+--- accessx.orig/Access.h 2003-09-19 19:00:42.000000000 +0300
++++ accessx/Access.h 2008-01-07 18:53:47.000000000 +0200
+@@ -21,7 +21,7 @@
+ *
+ */
+
+-#include <iostream.h>
++#include <iostream>
+ #include <math.h>
+
+ inline char* onoroff(int val)
+diff -ur accessx.orig/ax.C accessx/ax.C
+--- accessx.orig/ax.C 2003-09-19 19:09:31.000000000 +0300
++++ accessx/ax.C 2008-01-07 18:53:49.000000000 +0200
+@@ -20,6 +20,7 @@
+
+ #include "ax.h"
+
++using namespace std;
+
+ ///////////////////////////////////////////////////////////////////////////////
+ //
+diff -ur accessx.orig/ax.h accessx/ax.h
+--- accessx.orig/ax.h 2003-09-19 19:06:56.000000000 +0300
++++ accessx/ax.h 2008-01-07 18:53:51.000000000 +0200
+@@ -24,7 +24,7 @@
+
+ // Include Files
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/x11-misc/accessx/files/digest-accessx-0951-r1 b/x11-misc/accessx/files/digest-accessx-0951-r1
new file mode 100644
index 000000000000..d034ebeb7b3d
--- /dev/null
+++ b/x11-misc/accessx/files/digest-accessx-0951-r1
@@ -0,0 +1,3 @@
+MD5 e61286559b65e452705a6329646776f1 accessx0951.tar.gz 17199
+RMD160 505db30895d16137ff893ee0adbc1e8a8c706e4b accessx0951.tar.gz 17199
+SHA256 441e9316552a88d26b265a3074656ec56a84d8ea287d7dcebdb7a2b562111863 accessx0951.tar.gz 17199