summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-01-24 23:48:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-01-24 23:48:36 +0000
commitbc585935af91488717c3c9882d09758c4078eff9 (patch)
treebf34b15246f2cf3dde84514fda01c08afcac19ce /x11-libs
parentVersion bump. (diff)
downloadgentoo-2-bc585935af91488717c3c9882d09758c4078eff9.tar.gz
gentoo-2-bc585935af91488717c3c9882d09758c4078eff9.tar.bz2
gentoo-2-bc585935af91488717c3c9882d09758c4078eff9.zip
Version bump. 0.5 for last of gtk+:2 only release and 0.7 for testing API breakages, bug #340501. Add knotify to PDEPEND, bug #323593.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libnotify/ChangeLog13
-rw-r--r--x11-libs/libnotify/files/libnotify-0.7.1-gtk3-tests.patch110
-rw-r--r--x11-libs/libnotify/libnotify-0.4.5.ebuild11
-rw-r--r--x11-libs/libnotify/libnotify-0.5.2.ebuild38
-rw-r--r--x11-libs/libnotify/libnotify-0.7.1.ebuild57
-rw-r--r--x11-libs/libnotify/metadata.xml3
6 files changed, 226 insertions, 6 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index 1c35c1490313..4c9996f77597 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/libnotify
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.56 2010/12/03 22:57:11 wired Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.57 2011/01/24 23:48:36 eva Exp $
+
+*libnotify-0.7.1 (24 Jan 2011)
+*libnotify-0.5.2 (24 Jan 2011)
+
+ 24 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org> libnotify-0.4.5.ebuild,
+ +libnotify-0.5.2.ebuild, +libnotify-0.7.1.ebuild,
+ +files/libnotify-0.7.1-gtk3-tests.patch, metadata.xml:
+ Version bump. 0.5 for last of gtk+:2 only release and 0.7 for testing API
+ breakages, bug #340501. Add knotify to PDEPEND, bug #323593.
03 Dec 2010; Alex Alexander <wired@gentoo.org> libnotify-0.4.5.ebuild:
added x11-wm/awesome to PDEPEND, bug #342259
diff --git a/x11-libs/libnotify/files/libnotify-0.7.1-gtk3-tests.patch b/x11-libs/libnotify/files/libnotify-0.7.1-gtk3-tests.patch
new file mode 100644
index 000000000000..7d1230520366
--- /dev/null
+++ b/x11-libs/libnotify/files/libnotify-0.7.1-gtk3-tests.patch
@@ -0,0 +1,110 @@
+From 92983cacd36fa9b050f911bc4de09b8c4fb9f3b2 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Thu, 16 Dec 2010 00:01:13 +0100
+Subject: [PATCH] gentoo: do not build gtk+:3 tests if not required
+
+---
+ configure.ac | 5 +++++
+ tests/Makefile.am | 30 +++++++++++++++++-------------
+ 2 files changed, 22 insertions(+), 13 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 71609ed..7767c5b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -97,10 +97,15 @@ AC_SUBST(PACKAGE_LIBS)
+ AC_SUBST(PACKAGE_CFLAGS)
+ AC_SUBST(pkg_modules)
+
++AC_ARG_ENABLE([tests],
++ AS_HELP_STRING([--enable-tests], [Check for extra dependencies to build all tests]))
++AS_IF([test $enable_tests = yes], [
+ tests_modules="gtk+-3.0 >= $REQ_GTK_VERSION"
+ PKG_CHECK_MODULES(TESTS, [$tests_modules])
++])
+ AC_SUBST(TESTS_LIBS)
+ AC_SUBST(TESTS_CFLAGS)
++AM_CONDITIONAL([MORE_TESTS], [test $enable_tests = yes])
+
+ GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
+ AC_SUBST(GLIB_GENMARSHAL)
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 7acf9a3..2856a82 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -2,18 +2,15 @@ INCLUDES = \
+ -I$(top_srcdir) \
+ $(TESTS_CFLAGS)
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-replace \
+- test-replace-widget \
+ test-server-info \
+ test-default-action \
+ test-multi-actions \
+ test-action-icons \
+- test-image \
+ test-basic \
+ test-error \
+ test-markup \
+- test-persistence \
+ test-resident \
+ test-rtl \
+ test-size-changes \
+@@ -23,6 +20,22 @@ noinst_PROGRAMS = \
+ test-xy-actions \
+ test-xy-stress
+
++#if MORE_TESTS
++check_PROGRAMS += \
++ test-image \
++ test-replace-widget \
++ test-persistence
++
++test_replace_widget_SOURCES = test-replace-widget.c
++test_replace_widget_LDADD = $(common_ldflags)
++
++test_image_SOURCES = test-image.c
++test_image_LDADD = $(common_ldflags)
++
++test_persistence_SOURCES = test-persistence.c
++test_persistence_LDADD = $(common_ldflags)
++#endif
++
+ common_ldflags = \
+ $(top_builddir)/libnotify/libnotify.la \
+ $(TESTS_LIBS)
+@@ -30,9 +43,6 @@ common_ldflags = \
+ test_replace_SOURCES = test-replace.c
+ test_replace_LDADD = $(common_ldflags)
+
+-test_replace_widget_SOURCES = test-replace-widget.c
+-test_replace_widget_LDADD = $(common_ldflags)
+-
+ test_server_info_SOURCES = test-server-info.c
+ test_server_info_LDADD = $(common_ldflags)
+
+@@ -48,9 +58,6 @@ test_multi_actions_LDADD = $(common_ldflags)
+ test_action_icons_SOURCES = test-action-icons.c
+ test_action_icons_LDADD = $(common_ldflags)
+
+-test_image_SOURCES = test-image.c
+-test_image_LDADD = $(common_ldflags)
+-
+ test_basic_SOURCES = test-basic.c
+ test_basic_LDADD = $(common_ldflags)
+
+@@ -75,9 +82,6 @@ test_xy_stress_LDADD = $(common_ldflags)
+ test_rtl_SOURCES = test-rtl.c
+ test_rtl_LDADD = $(common_ldflags)
+
+-test_persistence_SOURCES = test-persistence.c
+-test_persistence_LDADD = $(common_ldflags)
+-
+ test_resident_SOURCES = test-resident.c
+ test_resident_LDADD = $(common_ldflags)
+
+--
+1.7.4.rc2
+
diff --git a/x11-libs/libnotify/libnotify-0.4.5.ebuild b/x11-libs/libnotify/libnotify-0.4.5.ebuild
index 12dc3061f5e4..030fbaf74ce0 100644
--- a/x11-libs/libnotify/libnotify-0.4.5.ebuild
+++ b/x11-libs/libnotify/libnotify-0.4.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.4.5.ebuild,v 1.16 2010/12/03 22:57:11 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.4.5.ebuild,v 1.17 2011/01/24 23:48:36 eva Exp $
EAPI=2
@@ -18,9 +18,12 @@ RDEPEND=">=x11-libs/gtk+-2.6:2
>=dev-libs/dbus-glib-0.76"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-PDEPEND="|| ( x11-misc/notification-daemon
+PDEPEND="|| (
+ x11-misc/notification-daemon
xfce-extra/xfce4-notifyd
- >=x11-wm/awesome-3.4.4 )"
+ >=x11-wm/awesome-3.4.4
+ kde-base/knotify
+)"
src_configure() {
econf \
diff --git a/x11-libs/libnotify/libnotify-0.5.2.ebuild b/x11-libs/libnotify/libnotify-0.5.2.ebuild
new file mode 100644
index 000000000000..187d2fe41eab
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.5.2.ebuild,v 1.1 2011/01/24 23:48:36 eva Exp $
+
+EAPI="3"
+
+inherit gnome.org
+
+DESCRIPTION="Notifications library"
+HOMEPAGE="http://www.galago-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ >=dev-libs/dbus-glib-0.76"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+PDEPEND="|| (
+ x11-misc/notification-daemon
+ xfce-extra/xfce4-notifyd
+ >=x11-wm/awesome-3.4.4
+ kde-base/knotify
+)"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}
diff --git a/x11-libs/libnotify/libnotify-0.7.1.ebuild b/x11-libs/libnotify/libnotify-0.7.1.ebuild
new file mode 100644
index 000000000000..07e9f9450a9d
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.7.1.ebuild,v 1.1 2011/01/24 23:48:35 eva Exp $
+
+EAPI="3"
+
+inherit autotools eutils gnome.org
+
+DESCRIPTION="Notifications library"
+HOMEPAGE="http://www.galago-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +introspection test"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.14 )
+ test? ( >=x11-libs/gtk+-2.90:3 )"
+PDEPEND="|| (
+ x11-misc/notification-daemon
+ xfce-extra/xfce4-notifyd
+ >=x11-wm/awesome-3.4.4
+ kde-base/knotify
+)"
+
+src_prepare() {
+ # Add configure switch for gtk+:3 based tests
+ # and make tests build only when needed
+ epatch "${FILESDIR}/${PN}-0.7.1-gtk3-tests.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libnotify.so.1
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libnotify.so.1
+}
diff --git a/x11-libs/libnotify/metadata.xml b/x11-libs/libnotify/metadata.xml
index 854288052d19..0b2305e0efdc 100644
--- a/x11-libs/libnotify/metadata.xml
+++ b/x11-libs/libnotify/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>freedesktop</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ </use>
</pkgmetadata>