summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJae Yang Kwak <jayskwak@gentoo.org>2003-07-19 15:11:27 +0000
committerJae Yang Kwak <jayskwak@gentoo.org>2003-07-19 15:11:27 +0000
commitafaaa83a18a1f67017646d8d641d7435710ee907 (patch)
treeeb37b8d38025000161d278912f59e9e77660780e /x11-libs
parentget rid of empty dir (diff)
downloadgentoo-2-afaaa83a18a1f67017646d8d641d7435710ee907.tar.gz
gentoo-2-afaaa83a18a1f67017646d8d641d7435710ee907.tar.bz2
gentoo-2-afaaa83a18a1f67017646d8d641d7435710ee907.zip
Add Korean xim patch
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog7
-rw-r--r--x11-libs/qt/Manifest3
-rw-r--r--x11-libs/qt/files/qt-3.1.2-korean-xim.patch114
-rw-r--r--x11-libs/qt/qt-3.1.2-r5.ebuild187
4 files changed, 310 insertions, 1 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index a1e613e16316..13e96abf8ba6 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.74 2003/07/11 09:19:09 brain Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.75 2003/07/19 15:11:27 jayskwak Exp $
+
+*qt-3.1.2-r5 (19 Jul 2003)
+
+ 19 Jul 2003; Jay Kwak <jayskwak@gentoo.org> qt-3.1.2-r5.ebuild
+ Add Korean xim patch
*qt-3.1.2-r4 (11 Jul 2003)
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index eec6315d29fc..2bc600151878 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -8,6 +8,7 @@ MD5 e81d2182a929c891d3c3b0b465e7ac3c qt-3.1.2-r3.ebuild 5027
MD5 703ba8038e5b2979c00d10ffffb3313d qt-3.1.2-r4.ebuild 5072
MD5 c31bb1b07af43f08f17f8c9ad1470cce qt-3.2.0_beta1.ebuild 4497
MD5 d8f9c7d8ddb12f1a412670d497215015 qt-3.2.0_beta2.ebuild 4497
+MD5 cc61e94fa529d606e4475f9735966f93 qt-3.1.2-r5.ebuild 5114
MD5 08cdd879d3418837cf4bad594dc0f91f files/45qtdir2 16
MD5 2d5b68b38185a30a28ffb2b652258cb8 files/45qt3 83
MD5 7dc4f78d52452c28ba797ffc7db34f23 files/50qtdir3 16
@@ -27,3 +28,5 @@ MD5 bf7aed227565288222ea889c81b1e363 files/qt-3.1.2-qlistview-dnd.diff 469
MD5 e9b2e2fbde862abb62cdfa78e62a35b6 files/qt-3.1.2-qmlined.diff 320
MD5 c6dc1b6fadcb4897d4c7b0a768c2d196 files/qt-3.1.2-r3-qsocket.diff 447
MD5 e4b92fbf81b7fc94c5d337e1675476d7 files/qt-x11-free-3.0.5-ko_input.patch 12682
+MD5 953be971128fb1a5ad7d9893f657e13c files/qt-3.1.2-korean-xim.patch 4285
+MD5 f197d87f2b33685cadba08c9cf2d08ee files/digest-qt-3.1.2-r5 72
diff --git a/x11-libs/qt/files/qt-3.1.2-korean-xim.patch b/x11-libs/qt/files/qt-3.1.2-korean-xim.patch
new file mode 100644
index 000000000000..601039f000b9
--- /dev/null
+++ b/x11-libs/qt/files/qt-3.1.2-korean-xim.patch
@@ -0,0 +1,114 @@
+diff -uNr qt-x11-free-3.1.2.orig/src/kernel/qapplication_x11.cpp qt-x11-free-3.1.2/src/kernel/qapplication_x11.cpp
+--- qt-x11-free-3.1.2.orig/src/kernel/qapplication_x11.cpp 2003-02-24 08:30:07.000000000 +0000
++++ qt-x11-free-3.1.2/src/kernel/qapplication_x11.cpp 2003-06-11 11:12:48.000000000 +0100
+@@ -3135,7 +3135,7 @@
+ if ( inPopupMode() ) // no focus widget, see if we have a popup
+ keywidget = (QETWidget*) activePopupWidget();
+ else if ( widget )
+- keywidget = (QETWidget*)widget->topLevelWidget();
++ keywidget = widget->focusWidget()?(QETWidget*)widget->focusWidget():widget;
+ }
+ }
+ }
+@@ -3166,11 +3166,12 @@
+ if ( inPopupMode() ) // no focus widget, see if we have a popup
+ keywidget = (QETWidget*) activePopupWidget();
+ else if ( widget )
+- keywidget = (QETWidget*)widget->topLevelWidget();
++ keywidget = widget->focusWidget()?(QETWidget*)widget->focusWidget():widget;
+ }
+ }
+ }
+
++#if 0
+ /*
+ if the composition string has been emptied, we need to send
+ an IMEnd event. however, we have no way to tell if the user
+@@ -3208,6 +3209,7 @@
+
+ qt_compose_emptied = FALSE;
+ }
++#endif // remove
+ #endif // QT_NO_XIM
+
+ return 1;
+@@ -3454,6 +3456,7 @@
+ case XKeyRelease:
+ {
+ if ( keywidget && keywidget->isEnabled() ) { // should always exist
++#if 0
+ #ifndef QT_NO_XIM
+ if ( (qt_xim_style & XIMPreeditCallbacks) && event->xkey.keycode == 0 ) {
+ // input method has sent us a commit string
+@@ -3481,6 +3484,7 @@
+ }
+ } else
+ #endif // !QT_NO_XIM
++#endif // remove
+ {
+ // qDebug( "sending key event" );
+ keywidget->translateKeyEvent( event, grabbed );
+@@ -4913,6 +4917,12 @@
+ if ( qic ) {
+ mb=TRUE;
+ count = qic->lookupString(&xkeyevent, chars, &key, &status);
++ if ( qic->composing && qic->focusWidget ) {
++ QIMEvent event(QEvent::IMEnd, QString::null, -1);
++ QApplication::sendEvent(qic->focusWidget, &event);
++ qic->composing = FALSE;
++ qic->focusWidget = 0;
++ }
+ }
+ }
+ if ( !mb ) {
+diff -uNr qt-x11-free-3.1.2.orig/src/kernel/qfont_x11.cpp qt-x11-free-3.1.2/src/kernel/qfont_x11.cpp
+--- qt-x11-free-3.1.2.orig/src/kernel/qfont_x11.cpp 2003-02-24 08:30:15.000000000 +0000
++++ qt-x11-free-3.1.2/src/kernel/qfont_x11.cpp 2003-06-11 11:17:51.000000000 +0100
+@@ -1557,7 +1557,8 @@
+ *scale = 1.;
+ }
+
+- mono_value = request.fixedPitch ? XFT_MONO : XFT_PROPORTIONAL;
++ mono_value = !request.fixedPitch || familyName == "monospace" || familyName == "gulimche"
++ ? XFT_PROPORTIONAL : XFT_MONO;
+
+ switch (request.styleHint) {
+ case QFont::SansSerif:
+@@ -1569,7 +1570,7 @@
+ break;
+ case QFont::TypeWriter:
+ generic_value = "mono";
+- mono_value = XFT_MONO;
++ mono_value = XFT_PROPORTIONAL;
+ break;
+ }
+
+diff -uNr qt-x11-free-3.1.2.orig/src/kernel/qinputcontext_x11.cpp qt-x11-free-3.1.2/src/kernel/qinputcontext_x11.cpp
+--- qt-x11-free-3.1.2.orig/src/kernel/qinputcontext_x11.cpp 2003-02-24 08:30:17.000000000 +0000
++++ qt-x11-free-3.1.2/src/kernel/qinputcontext_x11.cpp 2003-06-11 11:12:48.000000000 +0100
+@@ -154,6 +154,13 @@
+ }
+ }
+
++ if (! qic->composing ) {
++ qic->composing = TRUE;
++ qic->focusWidget = qApp->focusWidget();
++ QIMEvent startevent(QEvent::IMStart, QString::null, -1);
++ QApplication::sendEvent(qic->focusWidget, &startevent);
++ }
++
+ if (! qic->composing || ! qic->focusWidget) {
+ // qDebug("compose event: invalid compose event %d %p",
+ // qic->composing, qic->focusWidget);
+diff -uNr qt-x11-free-3.1.2.orig/src/kernel/qrichtext.cpp qt-x11-free-3.1.2/src/kernel/qrichtext.cpp
+--- qt-x11-free-3.1.2.orig/src/kernel/qrichtext.cpp 2003-02-24 08:30:11.000000000 +0000
++++ qt-x11-free-3.1.2/src/kernel/qrichtext.cpp 2003-06-11 11:12:56.000000000 +0100
+@@ -4645,7 +4645,7 @@
+ color.setHsv( h1, s1, ( v1 + v2 ) / 2 );
+ painter.setPen( cg.color( QColorGroup::Text ) );
+ } else if ( selection == QTextDocument::IMSelectionText ) {
+- color = cg.color( QColorGroup::Foreground );
++ color = cg.color( QColorGroup::Highlight );
+ painter.setPen( cg.color( QColorGroup::HighlightedText ) );
+ } else if ( !hasdoc || document()->invertSelectionText( selection ) ) {
+ painter.setPen( cg.color( QColorGroup::HighlightedText ) );
diff --git a/x11-libs/qt/qt-3.1.2-r5.ebuild b/x11-libs/qt/qt-3.1.2-r5.ebuild
new file mode 100644
index 000000000000..cd87286c47db
--- /dev/null
+++ b/x11-libs/qt/qt-3.1.2-r5.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.2-r5.ebuild,v 1.1 2003/07/19 15:11:27 jayskwak Exp $
+
+inherit eutils
+
+IUSE="cups nas postgres opengl mysql odbc gif"
+
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+LICENSE="QPL-1.0 | GPL-2"
+
+# WARNING: do not give this ebuild keywords that >=kdelibs-3.1.1, >=kdebase-3.1.1-r1 don't have
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ media-libs/lcms
+ media-libs/jpeg
+ >=media-libs/libmng-1.0.0
+ >=media-libs/freetype-2
+ virtual/xft
+ nas? ( >=media-libs/nas-1.4.1 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ !=kde-base/kdelibs-3.1
+ !=kde-base/kdelibs-3.1-r1
+ !=kde-base/kdelibs-3.1-r2
+ !=kde-base/kdelibs-3.1-r3
+ !=kde-base/kdebase-3.1
+ !=kde-base/kdebase-3.1-r1
+ !=kde-base/kdebase-3.1.1"
+# WARNING: the versions blocked above are known to be buggy. DO NOT use them with this qt
+
+RDEPEND="$DEPEND
+ doc? ( ~app-doc/qt-docs-$PV )"
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ export QTDIR=${S}
+
+ unpack ${A}
+
+ cd ${S}
+
+ epatch ${FILESDIR}/designer.diff
+ epatch ${FILESDIR}/${P}-qmlined.diff
+ epatch ${FILESDIR}/${P}-r3-qsocket.diff
+ epatch ${FILESDIR}/${P}-qlistview-dnd.diff
+ epatch ${FILESDIR}/${P}-korean-xim.patch
+
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+
+ cd mkspecs/linux-g++
+ # use env's $CC, $CXX
+ if [ -n "$CXX" ]; then
+ einfo 'Using environment definition of $CXX'
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= g++:= ${CXX}:" qmake.conf.orig > qmake.conf
+ fi
+ if [ -n "$CC" ]; then
+ einfo 'Using environment definition of $CC'
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= gcc:= ${CC}:" qmake.conf.orig > qmake.conf
+ fi
+
+ # hppa people, please review the following
+
+ # hppa need some additional flags
+ if [ "${ARCH}" = "hppa" ]; then
+ echo "QMAKE_CFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_CXXFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_LFLAGS += -ffunction-sections -Wl,--stub-group-size=25000" >> qmake.conf
+ fi
+}
+
+src_compile() {
+
+ # fix #11144; qt wants to create lock files etc. in that directory
+ [ -d "$QTBASE/etc/settings" ] && addwrite "$QTBASE/etc/settings"
+
+ export QTDIR=${S}
+
+ export LDFLAGS="-ldl"
+
+ use cups || myconf="${myconf} -no-cups"
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ use opengl && myconf="${myconf} -enable-module=opengl" || myconf="${myconf} -disable-opengl"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -verbose \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -ldl -lpthread -xft -platform linux-g++ -xplatform \
+ linux-g++ -xrender -prefix ${QTBASE} -fast ${myconf} || die
+
+ export QTDIR=${S}
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.3.1.2 lib/libqui.so.1.0.0 lib/lib{editor,qassistantclient,designer}.a
+ cd ${D}$QTBASE/lib
+ for x in libqui.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.1.2->3.1->3->.so
+ ln -s libqt-mt.so.3.1.2 libqt-mt.so.3.1
+ ln -s libqt-mt.so.3.1 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.3.1.2 libqt.so.3.1.2
+ ln -s libqt-mt.so.3.1 libqt.so.3.1
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${S}:${QTBASE}:g" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}
+pkg_postinst() {
+
+ ewarn "If you upgraded from QT 3.0.x to 3.1.x, you should remerge any copies"
+ ewarn "of kdelibs you have installed. Otherwise, other kde packages may not"
+ ewarn "compile properly. If you upgraded QT from 3.0.x to 3.1.x in the past"
+ ewarn "but have not remerged kdelib, since then, you should proobably do so now."
+
+}