summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2006-12-18 22:46:52 +0000
committerMatti Bickel <mabi@gentoo.org>2006-12-18 22:46:52 +0000
commita99a7fa02e23ad42688415b3a897260adf1f1bbc (patch)
treea8d76202ee6d945e3322d760cca30d21e999db42 /x11-libs
parentVersion bump (bug #158269). (diff)
downloadgentoo-2-a99a7fa02e23ad42688415b3a897260adf1f1bbc.tar.gz
gentoo-2-a99a7fa02e23ad42688415b3a897260adf1f1bbc.tar.bz2
gentoo-2-a99a7fa02e23ad42688415b3a897260adf1f1bbc.zip
Adding new version not building against fox-1.0 anymore
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fxscintilla/ChangeLog7
-rw-r--r--x11-libs/fxscintilla/files/digest-fxscintilla-1.62-r23
-rw-r--r--x11-libs/fxscintilla/fxscintilla-1.62-r2.ebuild70
3 files changed, 79 insertions, 1 deletions
diff --git a/x11-libs/fxscintilla/ChangeLog b/x11-libs/fxscintilla/ChangeLog
index a1b744d37bbc..8b5375e2d9d7 100644
--- a/x11-libs/fxscintilla/ChangeLog
+++ b/x11-libs/fxscintilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fxscintilla
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.17 2006/10/31 10:27:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.18 2006/12/18 22:46:52 mabi Exp $
+
+*fxscintilla-1.62-r2 (18 Dec 2006)
+
+ 18 Dec 2006; Matti Bickel <mabi@gentoo.org> +fxscintilla-1.62-r2.ebuild:
+ Add fxscintilla-1.62-r2 which doesn't build against fox-1.0* anymore
31 Oct 2006; Christian Faulhammer <opfer@gentoo.org>
fxscintilla-1.71.ebuild:
diff --git a/x11-libs/fxscintilla/files/digest-fxscintilla-1.62-r2 b/x11-libs/fxscintilla/files/digest-fxscintilla-1.62-r2
new file mode 100644
index 000000000000..c584418c90d8
--- /dev/null
+++ b/x11-libs/fxscintilla/files/digest-fxscintilla-1.62-r2
@@ -0,0 +1,3 @@
+MD5 c4cb1b9d954b92e1e1fdcb75597662c6 fxscintilla-1.62.tar.gz 833249
+RMD160 fa191090b252d5f631a7a9d0d935749bb3a9c246 fxscintilla-1.62.tar.gz 833249
+SHA256 5db9a3b17bee7f8e4b4f877d57e253bee7122e5b081adb41791faabba25c194c fxscintilla-1.62.tar.gz 833249
diff --git a/x11-libs/fxscintilla/fxscintilla-1.62-r2.ebuild b/x11-libs/fxscintilla/fxscintilla-1.62-r2.ebuild
new file mode 100644
index 000000000000..6344eb1f1b38
--- /dev/null
+++ b/x11-libs/fxscintilla/fxscintilla-1.62-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-1.62-r2.ebuild,v 1.1 2006/12/18 22:46:52 mabi Exp $
+
+inherit eutils
+
+DESCRIPTION="A free source code editing component for the FOX-Toolkit"
+HOMEPAGE="http://www.nongnu.org/fxscintilla/"
+SRC_URI="http://savannah.nongnu.org/download/fxscintilla/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
+IUSE="doc"
+
+DEPEND="=x11-libs/fox-1.2*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/1.62-shared-libs.patch || die
+ epatch ${FILESDIR}/1.62-fox-SLOT.patch || die
+
+ einfo "Running autoreconf..."
+ touch NEWS AUTHORS
+ autoreconf --install --force || die "autoreconf error"
+}
+
+src_compile () {
+ # Borrowed from wxGTK ebuild
+
+ einfo "Building ${PN} for FOX-1.2..."
+ mkdir ${S}/build_1_2
+ cd ${S}/build_1_2
+ ../configure \
+ --prefix=/usr \
+ --includedir=/usr/include \
+ --libdir=/usr/lib \
+ ${EXTRA_ECONF} \
+ --enable-nolexer \
+ --with-foxinclude=${ROOT}usr/include \
+ --with-foxlib=${ROOT}usr/lib \
+ || die "configure error"
+ emake || die "make error"
+}
+
+src_install () {
+ cd ${S}/build_1_2
+ make DESTDIR="${D}" install || die "make install error"
+
+ cd ${S}
+ dodoc README
+ if use doc ; then
+ dodoc scintilla/doc/Lexer.txt
+ dohtml scintilla/doc/*
+ fi
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "New as of 1.62-r2:"
+ ewarn "FXScintilla is now built only against FOX-1.2."
+ ewarn "For FOX-1.2, the library is called libfxscintilla-1.2."
+ ewarn "Anything linked against previous releases of FOX-1.2 and fxscintilla"
+ ewarn "may need to be rebuilt."
+ ewarn
+ einfo "The nolexer libraries are now included in this release as well."
+ epause 5
+}