summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-10-31 14:33:29 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-10-31 14:33:29 +0000
commit31dee3e51b4c015d59876b48681ad11bc1a26f2d (patch)
tree1a5a03bf42496d6a55824539f3b3f9ce37ff2ca4 /x11-libs
parentMarking libxdg-basedir-1.0.2 ppc64 for bug 287216 (diff)
downloadgentoo-2-31dee3e51b4c015d59876b48681ad11bc1a26f2d.tar.gz
gentoo-2-31dee3e51b4c015d59876b48681ad11bc1a26f2d.tar.bz2
gentoo-2-31dee3e51b4c015d59876b48681ad11bc1a26f2d.zip
Fix parallel build with patch by Martin von Gagern from bug 287825
(Portage version: 2.1.7.2/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog6
-rw-r--r--x11-libs/pango/files/pango-1.26.0-fix-parallel-build.patch27
-rw-r--r--x11-libs/pango/pango-1.26.0.ebuild5
3 files changed, 36 insertions, 2 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index ce23568b3407..62f7569ab6cb 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/pango
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.275 2009/10/29 21:25:57 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.276 2009/10/31 14:33:29 nirbheek Exp $
+
+ 31 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org> pango-1.26.0.ebuild,
+ +files/pango-1.26.0-fix-parallel-build.patch:
+ Fix parallel build with patch by Martin von Gagern from bug 287825
*pango-1.26.0 (29 Oct 2009)
diff --git a/x11-libs/pango/files/pango-1.26.0-fix-parallel-build.patch b/x11-libs/pango/files/pango-1.26.0-fix-parallel-build.patch
new file mode 100644
index 000000000000..fd859b66cb16
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.26.0-fix-parallel-build.patch
@@ -0,0 +1,27 @@
+Avoid parallel build issues.
+
+The pango-view.1 manpage requires the pango-view binary because help2man
+needs to execute it. Instead of calling make as one of the commands,
+however, the executable should simply be declared as a dependency. This
+avoids two make jobs building the same target at the same time, which may
+otherwise lead to failing builds or even broken applications.
+
+2009-10-30 Martin von Gagern
+
+References:
+http://bugs.gentoo.org/287825
+Upstream bug:
+https://bugzilla.gnome.org/show_bug.cgi?id=600207
+---
+--- pango-view/Makefile.am
++++ pango-view/Makefile.am
+@@ -88,8 +88,7 @@ MAINTAINERCLEANFILES = pango-view.1
+
+ dist_man_MANS = pango-view.1
+
+-$(srcdir)/pango-view.1: ../configure.in $(pango_view_SOURCES)
+- $(MAKE) $(AM_MAKEFLAGS) pango-view$(EXEEXT)
++$(srcdir)/pango-view.1: ../configure.in $(pango_view_SOURCES) pango-view$(EXEEXT)
+ $(AM_V_GEN) $(top_builddir)/missing --run \
+ help2man --no-info --section=1 \
+ --help-option="--help-all" --output="$@.tmp" \
diff --git a/x11-libs/pango/pango-1.26.0.ebuild b/x11-libs/pango/pango-1.26.0.ebuild
index 5b6fd860af2a..142faa3afbc4 100644
--- a/x11-libs/pango/pango-1.26.0.ebuild
+++ b/x11-libs/pango/pango-1.26.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.26.0.ebuild,v 1.1 2009/10/29 21:25:57 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.26.0.ebuild,v 1.2 2009/10/31 14:33:29 nirbheek Exp $
EAPI="2"
GCONF_DEBUG="yes"
@@ -66,6 +66,9 @@ src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=596506
epatch "${FILESDIR}/${PN}-1.26.0-introspection-automagic.patch"
+ # Fix parallel build, bug 287825
+ epatch "${FILESDIR}/${PN}-1.26.0-fix-parallel-build.patch"
+
eautoreconf
}