summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-21 19:56:15 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-21 19:56:15 +0000
commit744f665b45eb40958e700c94270df81003721f79 (patch)
treecb8e6cf16b2c6d2d00945eac95970b6d6e4be327 /x11-libs/vte
parentMask >=vte-0.30 (requires gtk+-3.2). (diff)
downloadgentoo-2-744f665b45eb40958e700c94270df81003721f79.tar.gz
gentoo-2-744f665b45eb40958e700c94270df81003721f79.tar.bz2
gentoo-2-744f665b45eb40958e700c94270df81003721f79.zip
Add vte-0.30.1 from the gnome overlay.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/vte-0.30.1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index c75550e5deee..5cd7397e6076 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.291 2011/10/21 15:06:55 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.292 2011/10/21 19:56:15 tetromino Exp $
+
+*vte-0.30.1 (21 Oct 2011)
+
+ 21 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +vte-0.30.1.ebuild:
+ Add vte-0.30.1 from the gnome overlay.
+ Notable changes: better accessibility support, and no more gtk2 version.
21 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> vte-0.28.2-r200.ebuild,
vte-0.28.2-r300.ebuild:
diff --git a/x11-libs/vte/vte-0.30.1.ebuild b/x11-libs/vte/vte-0.30.1.ebuild
new file mode 100644
index 000000000000..92d2c4c19ca3
--- /dev/null
+++ b/x11-libs/vte/vte-0.30.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1.ebuild,v 1.1 2011/10/21 19:56:15 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME terminal widget"
+HOMEPAGE="http://git.gnome.org/browse/vte"
+
+LICENSE="LGPL-2"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade +introspection"
+
+PDEPEND="x11-libs/gnome-pty-helper"
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.1.9:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXft
+
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+pkg_setup() {
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ G2CONF="${G2CONF}
+ --disable-gnome-pty-helper
+ --disable-deprecation
+ --disable-maintainer-mode
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+}