summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:11:42 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:11:42 +0000
commit6ca647b0d891b8b0bdc1dafb2d7369778ebee9a6 (patch)
tree2f7580e3f228e8b7ae44dc1f741057546d4b95d3 /x11-libs/qt-webkit
parentVersion bump Qt 4.7.2 (diff)
downloadgentoo-2-6ca647b0d891b8b0bdc1dafb2d7369778ebee9a6.tar.gz
gentoo-2-6ca647b0d891b8b0bdc1dafb2d7369778ebee9a6.tar.bz2
gentoo-2-6ca647b0d891b8b0bdc1dafb2d7369778ebee9a6.zip
Version bump Qt 4.7.2
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog10
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.2.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index c312107bb47d..b386a1c2779b 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-webkit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.114 2010/12/23 07:57:31 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.115 2011/03/01 19:11:42 tampakrap Exp $
+
+*qt-webkit-4.7.2 (01 Mar 2011)
+
+ 01 Mar 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-webkit-4.7.2.ebuild:
+ Version bump Qt 4.7.2
23 Dec 2010; Samuli Suominen <ssuominen@gentoo.org>
qt-webkit-4.6.3-r1.ebuild:
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.2.ebuild
new file mode 100644
index 000000000000..5d222c245878
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.7.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.2.ebuild,v 1.1 2011/03/01 19:11:42 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus +jit kde"
+
+DEPEND="
+ dev-db/sqlite:3
+ ~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
+ media-sound/phonon[aqua=] ) )
+ kde? ( || ( media-sound/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/JavaScriptCore
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit -system-sqlite $(qt_use jit javascript-jit) $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}