summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:45:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:45:59 +0000
commit91c94bd99db20f9475ee9ed4fdfbfc7fdcebe78c (patch)
tree3df62cc2c45c64a2326d17322127883a83fe1bf3 /x11-libs/qt-phonon
parentQt 4.5.1 release version bump (diff)
downloadgentoo-2-91c94bd99db20f9475ee9ed4fdfbfc7fdcebe78c.tar.gz
gentoo-2-91c94bd99db20f9475ee9ed4fdfbfc7fdcebe78c.tar.bz2
gentoo-2-91c94bd99db20f9475ee9ed4fdfbfc7fdcebe78c.zip
Qt 4.5.1 release version bump
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog8
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.5.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index 1d2db299ee28..fbe2593b05e5 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.26 2009/03/21 11:51:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.27 2009/04/27 19:45:59 hwoarang Exp $
+
+*qt-phonon-4.5.1 (27 Apr 2009)
+
+ 27 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
+ +qt-phonon-4.5.1.ebuild:
+ Version bump to 4.5.1
21 Mar 2009; Raúl Porcel <armin76@gentoo.org> qt-phonon-4.5.0.ebuild:
Re-add ~alpha/~ia64 since qt-webkit needs it
diff --git a/x11-libs/qt-phonon/qt-phonon-4.5.1.ebuild b/x11-libs/qt-phonon/qt-phonon-4.5.1.ebuild
new file mode 100644
index 000000000000..abd58175274e
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.5.1.ebuild,v 1.1 2009/04/27 19:45:59 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="+dbus"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=,glib,qt3support]
+ !kde-base/phonon-kde
+ !kde-base/phonon-xine
+ !media-sound/phonon
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ dbus? ( =x11-libs/qt-dbus-${PV}[debug=] )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/phonon
+src/plugins/phonon"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/
+src"
+
+QCONFIG_ADD="phonon"
+QCONFIG_DEFINE="QT_GSTREAMER"
+
+src_configure() {
+ myconf="${myconf} -phonon -no-opengl -no-svg
+ $(qt_use dbus qdbus)"
+
+ qt4-build_src_configure
+}
+
+# bug 265586
+src_install() {
+ qt4-build_src_install
+ insinto ${QTHEADERDIR}
+ doins -r "${S}"/include/Phonon || die "failed to install Phonon headers"
+}