summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-11 09:14:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-11 09:14:42 +0000
commitf48d554eaeb34c36b9d02fa9e8edf2bd3346e85e (patch)
tree20a2b7ac368853ade1ed1f9cb12f5795b843b83b /x11-libs/libvdpau
parentStable for amd64, wrt bug #480568 (diff)
downloadgentoo-2-f48d554eaeb34c36b9d02fa9e8edf2bd3346e85e.tar.gz
gentoo-2-f48d554eaeb34c36b9d02fa9e8edf2bd3346e85e.tar.bz2
gentoo-2-f48d554eaeb34c36b9d02fa9e8edf2bd3346e85e.zip
Version bump wrt #479558
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-libs/libvdpau')
-rw-r--r--x11-libs/libvdpau/ChangeLog7
-rw-r--r--x11-libs/libvdpau/libvdpau-0.7.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-libs/libvdpau/ChangeLog b/x11-libs/libvdpau/ChangeLog
index 7ea52cbe9fd0..8f056374f3ae 100644
--- a/x11-libs/libvdpau/ChangeLog
+++ b/x11-libs/libvdpau/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libvdpau
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.29 2013/07/30 18:59:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.30 2013/08/11 09:14:42 ssuominen Exp $
+
+*libvdpau-0.7 (11 Aug 2013)
+
+ 11 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +libvdpau-0.7.ebuild:
+ Version bump wrt #479558
30 Jul 2013; Michał Górny <mgorny@gentoo.org> libvdpau-0.5-r1.ebuild,
libvdpau-0.6.ebuild:
diff --git a/x11-libs/libvdpau/libvdpau-0.7.ebuild b/x11-libs/libvdpau/libvdpau-0.7.ebuild
new file mode 100644
index 000000000000..c4ddae0e640a
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/libvdpau-0.7.ebuild,v 1.1 2013/08/11 09:14:42 ssuominen Exp $
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="http://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND="x11-libs/libX11[${MULTILIB_USEDEP}]
+ dri? ( x11-libs/libXext[${MULTILIB_USEDEP}] )
+ !=x11-drivers/nvidia-drivers-180*
+ !=x11-drivers/nvidia-drivers-185*
+ !=x11-drivers/nvidia-drivers-190*
+ abi_x86_32? ( !app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( >=x11-proto/dri2proto-2.2 )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable doc documentation)
+ $(use dri || echo --disable-dri2)
+ )
+
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ prune_libtool_files --modules
+}