summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-04-30 13:26:15 +0000
committerBen de Groot <yngwin@gentoo.org>2009-04-30 13:26:15 +0000
commite74302b042015c33d0456210dc8c3d3e3edc8987 (patch)
treebeb97328bb4db90ddcbeea1ef8b637f7144f4eec /x11-libs/libqxt
parentVersion bump. (diff)
downloadgentoo-2-e74302b042015c33d0456210dc8c3d3e3edc8987.tar.gz
gentoo-2-e74302b042015c33d0456210dc8c3d3e3edc8987.tar.bz2
gentoo-2-e74302b042015c33d0456210dc8c3d3e3edc8987.zip
Version bump, clean up deps. Thanks to Markos "hwoarang" Chandras.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libqxt')
-rw-r--r--x11-libs/libqxt/ChangeLog7
-rw-r--r--x11-libs/libqxt/libqxt-0.5.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/x11-libs/libqxt/ChangeLog b/x11-libs/libqxt/ChangeLog
index 27e3d2b95316..f74ff8b2abf0 100644
--- a/x11-libs/libqxt/ChangeLog
+++ b/x11-libs/libqxt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libqxt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/ChangeLog,v 1.7 2009/02/07 20:15:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/ChangeLog,v 1.8 2009/04/30 13:26:15 yngwin Exp $
+
+*libqxt-0.5.0 (30 Apr 2009)
+
+ 30 Apr 2009; Ben de Groot <yngwin@gentoo.org> +libqxt-0.5.0.ebuild:
+ Version bump, clean up deps. Thanks to Markos "hwoarang" Chandras.
*libqxt-0.4-r1 (07 Feb 2009)
*libqxt-0.2.5-r1 (07 Feb 2009)
diff --git a/x11-libs/libqxt/libqxt-0.5.0.ebuild b/x11-libs/libqxt/libqxt-0.5.0.ebuild
new file mode 100644
index 000000000000..9d50f2c42195
--- /dev/null
+++ b/x11-libs/libqxt/libqxt-0.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.5.0.ebuild,v 1.1 2009/04/30 13:26:15 yngwin Exp $
+
+EAPI=2
+inherit eutils qt4
+
+DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
+HOMEPAGE="http://libqxt.org/"
+SRC_URI="http://bitbucket.org/${PN}/${PN}/downloads/${P}.tgz"
+
+LICENSE="|| ( CPL-1.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb crypt debug doc sql web"
+
+RDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ berkdb? ( x11-libs/qt-sql:4 sys-libs/db )
+ sql? ( x11-libs/qt-sql:4 )
+ crypt? ( >=dev-libs/openssl-0.9.8 x11-libs/qt-core:4[ssl] )
+ web? ( >=dev-libs/fcgi-2.4 )"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local myconf
+ myconf="-prefix /usr \
+ -libdir /usr/$(get_libdir) \
+ -docdir /usr/share/doc/${PF} \
+ -qmake-bin /usr/bin/qmake \
+ $(use debug && echo -debug) \
+ $(use !berkdb && echo -no-db -nomake berkeley) \
+ $(use !crypt && echo -nomake crypto -no-openssl) \
+ $(use !sql && echo -nomake sql) \
+ $(use !web && echo -nomake web)"
+ # fix pre-striped files issue
+ for i in $(ls "${S}"/src); do
+ sed -i "s/qxtbuild/nostrip\ qxtbuild/" "${S}"/src/${i}/${i}.pro
+ done
+ ./configure ${myconf} || die "configure failed"
+}
+
+#src_compile() {
+# # parallel compilation fails, bug #194730
+# emake -j1 || die "make failed"
+#}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc {AUTHORS,README,LICENSE,cpl1.0.txt}
+
+ if use doc; then
+ doxygen Doqsyfile
+ dohtml -r deploy/docs/*
+ fi
+}