summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-06 13:03:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-06 13:03:49 +0000
commit318306c09dfe84122453b40bdbf6daf2e22c33ea (patch)
tree1dc44751657aef2db8b8b02c5ff8735dc7fdbe6f /x11-libs/libqxt
parentMarked ppc stable for bug #288964. (diff)
downloadgentoo-2-318306c09dfe84122453b40bdbf6daf2e22c33ea.tar.gz
gentoo-2-318306c09dfe84122453b40bdbf6daf2e22c33ea.tar.bz2
gentoo-2-318306c09dfe84122453b40bdbf6daf2e22c33ea.zip
migrate to qt4-r2 and bump to 0.5.1
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libqxt')
-rw-r--r--x11-libs/libqxt/ChangeLog10
-rw-r--r--x11-libs/libqxt/libqxt-0.2.5-r1.ebuild16
-rw-r--r--x11-libs/libqxt/libqxt-0.4-r1.ebuild12
-rw-r--r--x11-libs/libqxt/libqxt-0.5.0.ebuild17
-rw-r--r--x11-libs/libqxt/libqxt-0.5.1.ebuild52
5 files changed, 79 insertions, 28 deletions
diff --git a/x11-libs/libqxt/ChangeLog b/x11-libs/libqxt/ChangeLog
index ed6d75ff30e6..e282fcf05378 100644
--- a/x11-libs/libqxt/ChangeLog
+++ b/x11-libs/libqxt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libqxt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/ChangeLog,v 1.11 2009/10/06 19:08:40 ayoy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/ChangeLog,v 1.12 2010/01/06 13:03:49 hwoarang Exp $
+
+*libqxt-0.5.1 (06 Jan 2010)
+
+ 06 Jan 2010; <hwoarang@gentoo.org> libqxt-0.2.5-r1.ebuild,
+ libqxt-0.4-r1.ebuild, libqxt-0.5.0.ebuild, +libqxt-0.5.1.ebuild:
+ migrate to qt4-r2 eclass and version bump to 0.5.1
06 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> libqxt-0.2.5-r1.ebuild:
Removed obsolete (and unneeded) QT4_BUILT_WITH_USE_CHECK
diff --git a/x11-libs/libqxt/libqxt-0.2.5-r1.ebuild b/x11-libs/libqxt/libqxt-0.2.5-r1.ebuild
index a3bc194a95f4..bbebc4b62bd0 100644
--- a/x11-libs/libqxt/libqxt-0.2.5-r1.ebuild
+++ b/x11-libs/libqxt/libqxt-0.2.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.2.5-r1.ebuild,v 1.3 2009/10/06 19:08:40 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.2.5-r1.ebuild,v 1.4 2010/01/06 13:03:49 hwoarang Exp $
-EAPI="1"
-inherit eutils qt4
+EAPI="2"
+inherit eutils qt4-r2
DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
HOMEPAGE="http://libqxt.org/"
@@ -22,7 +22,7 @@ DEPEND="x11-libs/qt-gui:4
fastcgi? ( >=dev-libs/fcgi-2.4 )"
RDEPEND="${DEPEND}"
-src_compile() {
+src_configure() {
local myconf
use debug && myconf="${myconf} -debug"
@@ -33,11 +33,9 @@ src_compile() {
sed -i "s/qxtbuild/nostrip\ qxtbuild/" "${S}"/src/${i}/${i}.pro
done
./configure -prefix /usr ${myconf}
+}
+src_compile() {
# fails with parallel build, bug 194730
emake -j1 || die "emake failed"
}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
-}
diff --git a/x11-libs/libqxt/libqxt-0.4-r1.ebuild b/x11-libs/libqxt/libqxt-0.4-r1.ebuild
index 381f0b8f0f87..e7844fc45e0e 100644
--- a/x11-libs/libqxt/libqxt-0.4-r1.ebuild
+++ b/x11-libs/libqxt/libqxt-0.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.4-r1.ebuild,v 1.2 2009/10/06 17:54:59 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.4-r1.ebuild,v 1.3 2010/01/06 13:03:49 hwoarang Exp $
EAPI=2
-inherit eutils qt4
+inherit eutils qt4-r2
DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
HOMEPAGE="http://libqxt.org/"
@@ -29,6 +29,8 @@ RDEPEND="x11-libs/qt-gui:4
DEPEND="${DEPEND}
doc? ( app-doc/doxygen )"
+DOCS="AUTHORS README LICENSE cpl1.0.txt"
+
src_configure() {
local myconf
myconf="-prefix /usr \
@@ -53,9 +55,7 @@ src_compile() {
}
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc {AUTHORS,README,LICENSE,cpl1.0.txt}
-
+ qt4-r2_src_install
if use doc; then
doxygen Doqsyfile
dohtml -r deploy/docs/*
diff --git a/x11-libs/libqxt/libqxt-0.5.0.ebuild b/x11-libs/libqxt/libqxt-0.5.0.ebuild
index 54d8a9322324..09c21a8e0609 100644
--- a/x11-libs/libqxt/libqxt-0.5.0.ebuild
+++ b/x11-libs/libqxt/libqxt-0.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.5.0.ebuild,v 1.2 2009/07/13 07:35:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.5.0.ebuild,v 1.3 2010/01/06 13:03:49 hwoarang Exp $
EAPI=2
-inherit eutils qt4
+inherit eutils qt4-r2
DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
HOMEPAGE="http://libqxt.org/"
@@ -27,6 +27,8 @@ PATCHES=(
"${FILESDIR}/libqxt-0.5.0-gcc4.4.patch"
)
+DOCS="AUTHORS README LICENSE cpl1.0.txt"
+
src_configure() {
local myconf
myconf="-prefix /usr \
@@ -45,15 +47,8 @@ src_configure() {
./configure ${myconf} || die "configure failed"
}
-#src_compile() {
-# # parallel compilation fails, bug #194730
-# emake -j1 || die "make failed"
-#}
-
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc {AUTHORS,README,LICENSE,cpl1.0.txt}
-
+ qt4-r2_src_install
if use doc; then
doxygen Doqsyfile
dohtml -r deploy/docs/*
diff --git a/x11-libs/libqxt/libqxt-0.5.1.ebuild b/x11-libs/libqxt/libqxt-0.5.1.ebuild
new file mode 100644
index 000000000000..ba3733344657
--- /dev/null
+++ b/x11-libs/libqxt/libqxt-0.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.5.1.ebuild,v 1.1 2010/01/06 13:03:49 hwoarang Exp $
+
+EAPI=2
+inherit eutils qt4-r2
+
+DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
+HOMEPAGE="http://libqxt.org/"
+SRC_URI="http://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="|| ( CPL-1.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb crypt debug doc sql web"
+
+RDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ berkdb? ( x11-libs/qt-sql:4 sys-libs/db )
+ sql? ( x11-libs/qt-sql:4 )
+ crypt? ( >=dev-libs/openssl-0.9.8 x11-libs/qt-core:4[ssl] )
+ web? ( >=dev-libs/fcgi-2.4 )"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS README LICENSE cpl1.0.txt"
+
+src_configure() {
+ local myconf
+ myconf="-prefix /usr \
+ -libdir /usr/$(get_libdir) \
+ -docdir /usr/share/doc/${PF} \
+ -qmake-bin /usr/bin/qmake \
+ $(use debug && echo -debug) \
+ $(use !berkdb && echo -no-db -nomake berkeley) \
+ $(use !crypt && echo -nomake crypto -no-openssl) \
+ $(use !sql && echo -nomake sql) \
+ $(use !web && echo -nomake web)"
+ # fix pre-striped files issue
+ for i in $(ls "${S}"/src); do
+ sed -i "s/qxtbuild/nostrip\ qxtbuild/" "${S}"/src/${i}/${i}.pro
+ done
+ ./configure ${myconf} || die "configure failed"
+}
+
+src_install() {
+ qt4-r2_src_install
+ if use doc; then
+ doxygen Doqsyfile
+ dohtml -r deploy/docs/*
+ fi
+}