summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-08-11 17:17:38 +0000
committerMatt Turner <mattst88@gentoo.org>2012-08-11 17:17:38 +0000
commitda8a24efb085c8f0e08c91a9aec01a44d12c2474 (patch)
tree152b5c3e09815445a01e2a0912e496c48878d0f6 /x11-libs/libXaw/libXaw-1.0.11-r1.ebuild
parentAdd fix from upstream PR52999 for hppa section conflict errors #405161 by Jer... (diff)
downloadgentoo-2-da8a24efb085c8f0e08c91a9aec01a44d12c2474.tar.gz
gentoo-2-da8a24efb085c8f0e08c91a9aec01a44d12c2474.tar.bz2
gentoo-2-da8a24efb085c8f0e08c91a9aec01a44d12c2474.zip
Add deprecated USE flag to control Xaw6 library.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libXaw/libXaw-1.0.11-r1.ebuild')
-rw-r--r--x11-libs/libXaw/libXaw-1.0.11-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libXaw/libXaw-1.0.11-r1.ebuild b/x11-libs/libXaw/libXaw-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..1d0ed51f9661
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.11-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.11-r1.ebuild,v 1.1 2012/08/11 17:17:38 mattst88 Exp $
+
+EAPI=4
+
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-proto/xproto
+ x11-proto/xextproto"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecacted xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}