summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-16 18:42:07 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-16 18:42:07 +0000
commitd48ae4191432ea210564967e21828f211a5fd786 (patch)
treed721d3ed2f1dec646d867536ed410678cc718600 /x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
parentStable for PPC (bug #340198). (diff)
downloadgentoo-2-d48ae4191432ea210564967e21828f211a5fd786.tar.gz
gentoo-2-d48ae4191432ea210564967e21828f211a5fd786.tar.bz2
gentoo-2-d48ae4191432ea210564967e21828f211a5fd786.zip
Remove -D.*DISABLE_DEPRECATED cflags (bug #323923 by Konstantin Likhomanov and others) and install examples properly (bug #99318).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild')
-rw-r--r--x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild b/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
index 4548fa12d3da..31df6d6b26d7 100644
--- a/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
+++ b/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild,v 1.3 2009/09/18 16:46:53 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild,v 1.4 2010/12/16 18:42:07 pacho Exp $
EAPI="2"
@@ -22,6 +22,15 @@ RDEPEND="x11-libs/gtk+:2
DEPEND=${RDEPEND}
+src_prepare() {
+ # Remove -D.*DISABLE_DEPRECATED cflags
+ find . -iname 'Makefile.am' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die "sed 1 failed"
+ # Do Makefile.in after Makefile.am to avoid automake maintainer-mode
+ find . -iname 'Makefile.in' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die "sed 2 failed"
+}
+
src_configure() {
econf \
--enable-libtool-lock \
@@ -40,6 +49,6 @@ src_install() {
if use examples; then
emake clean -C examples || die "Cleaning examples failed"
docinto examples
- dodoc "${S}/examples/*" || die "Copy examples to doc failed."
+ dodoc "${S}"/examples/* || die "Copy examples to doc failed."
fi
}