summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-06-26 20:24:11 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-06-26 20:24:11 +0000
commit02628bde4c16be1c56909231bbfebd5a285c8ee0 (patch)
treef9b2baf7d14fb72412181454f41c5bdc57bead70 /x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
parentInitial commit. New split samba ebuilds by dev-zero. (diff)
downloadgentoo-2-02628bde4c16be1c56909231bbfebd5a285c8ee0.tar.gz
gentoo-2-02628bde4c16be1c56909231bbfebd5a285c8ee0.tar.bz2
gentoo-2-02628bde4c16be1c56909231bbfebd5a285c8ee0.zip
New ebuild, import from scarabeus overlay
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild')
-rw-r--r--x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild b/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
new file mode 100644
index 000000000000..57ed94063f30
--- /dev/null
+++ b/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkdatabox/gtkdatabox-0.9.1.1.ebuild,v 1.1 2009/06/26 20:24:11 mrpouet Exp $
+
+EAPI="2"
+
+DESCRIPTION="Gtk+ Widgets for live display of large amounts of fluctuating numerical data"
+HOMEPAGE="http://sourceforge.net/projects/gtkdatabox/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples +glade test"
+
+RDEPEND="x11-libs/gtk+:2
+ glade? (
+ dev-util/glade:3
+ gnome-base/libglade )
+"
+
+DEPEND=${RDEPEND}
+
+src_configure() {
+ econf \
+ --enable-libtool-lock \
+ --disable-dependency-tracking \
+ $(use_enable glade libglade) \
+ $(use_enable glade) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable test gtktest)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc AUTHORS ChangeLog README TODO || "dodoc failed"
+
+ if use examples; then
+ emake clean -C examples || die "Cleaning examples failed"
+ docinto examples
+ dodoc "${S}/examples/*" || die "Copy examples to doc failed."
+ fi
+}