summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-04 19:32:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-04 19:32:08 +0000
commit53cfedbb29e2622dabb1f93bac8dabbf7e030056 (patch)
treede8724e7c85bb9fb0a88ae32557660b0f1e713a2 /x11-libs/gtkDPS
parentBump for 7.0RC3. (diff)
downloadgentoo-2-53cfedbb29e2622dabb1f93bac8dabbf7e030056.tar.gz
gentoo-2-53cfedbb29e2622dabb1f93bac8dabbf7e030056.tar.bz2
gentoo-2-53cfedbb29e2622dabb1f93bac8dabbf7e030056.zip
Clean up ebuild and fix m4 warnings.
(Portage version: 2.0.53)
Diffstat (limited to 'x11-libs/gtkDPS')
-rw-r--r--x11-libs/gtkDPS/ChangeLog8
-rw-r--r--x11-libs/gtkDPS/files/gtkDPS-0.3.4-m4.patch9
-rw-r--r--x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild36
3 files changed, 36 insertions, 17 deletions
diff --git a/x11-libs/gtkDPS/ChangeLog b/x11-libs/gtkDPS/ChangeLog
index 6ae6a828478e..6e59fd29d749 100644
--- a/x11-libs/gtkDPS/ChangeLog
+++ b/x11-libs/gtkDPS/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gtkDPS
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/ChangeLog,v 1.23 2005/12/03 17:52:50 nichoj Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/ChangeLog,v 1.24 2005/12/04 19:32:08 vapier Exp $
+
+ 04 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gtkDPS-0.3.4-m4.patch, gtkDPS-0.3.4.ebuild:
+ Clean up ebuild and fix m4 warnings.
03 Dec 2005; Joshua Nichols <nichoj@gentoo.org> gtkDPS-0.3.4.ebuild:
Fixed multilib-strict violation.
diff --git a/x11-libs/gtkDPS/files/gtkDPS-0.3.4-m4.patch b/x11-libs/gtkDPS/files/gtkDPS-0.3.4-m4.patch
new file mode 100644
index 000000000000..3308ec1c1646
--- /dev/null
+++ b/x11-libs/gtkDPS/files/gtkDPS-0.3.4-m4.patch
@@ -0,0 +1,9 @@
+Fix underquoting warnings
+
+--- gtkDPS.m4
++++ gtkDPS.m4
+@@ -2,3 +2,3 @@
+ dnl This macro is derived from guile.m4.
+-AC_DEFUN(AM_PATH_GTK_DPS,[dnl
++AC_DEFUN([AM_PATH_GTK_DPS],[dnl
+ AC_MSG_CHECKING(for GtkDPS)
diff --git a/x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild b/x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild
index 0418c2506a82..ef732dd427d7 100644
--- a/x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild
+++ b/x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild
@@ -1,39 +1,45 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild,v 1.19 2005/12/03 17:52:50 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.4.ebuild,v 1.20 2005/12/04 19:32:08 vapier Exp $
-inherit gnuconfig multilib
-
-IUSE="nls"
+inherit eutils multilib
DESCRIPTION="Set of functions, objects and widgets to use DPS easily with GTK"
SRC_URI="ftp://ftp.gyve.org/pub/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gyve.org/gtkDPS/"
+
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="x86 sparc alpha ppc amd64 ia64"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="nls"
-DEPEND="virtual/libc
- =x11-libs/gtk+-1.2*
+DEPEND="=x11-libs/gtk+-1.2*
virtual/x11
nls? ( sys-devel/gettext )"
-src_compile() {
- # needed for alpha and amd64 ... but run everywhere
- gnuconfig_update || die "gnuconfig_update failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
+}
+src_compile() {
if ! use nls ; then
myconf="--disable-nls"
fi
-
- ./configure --prefix=/usr --host=${CHOST} \
- --with-x --with-dps $myconf --libdir=${D}/usr/$(get_libdir) || die
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-x \
+ --with-dps $myconf \
+ --libdir=${D}/usr/$(get_libdir) \
+ || die
#Very ugly workaround
use nls && echo '#define LOCALEDIR "/usr/share/locale"' >> config.h
make || die
}
src_install () {
- make prefix=${D}/usr install || die
- dodoc COPYING* ChangeLog GTKDPS-VERSION HACKING NEWS README TODO
+ make prefix="${D}"/usr install || die
+ dodoc ChangeLog GTKDPS-VERSION HACKING NEWS README TODO
}