summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-10-08 16:37:54 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-10-08 16:37:54 +0000
commit93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb (patch)
tree9e25fd3c1279e093f618dcdd8f9a820e1f99e9f2 /x11-libs/gai/gai-0.5.6.ebuild
parentversion bump, #66773 (diff)
downloadgentoo-2-93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb.tar.gz
gentoo-2-93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb.tar.bz2
gentoo-2-93fb5553c9b5ad41bc71ebe262ab29d48f10a0eb.zip
version bump. fixes bug 59277
Diffstat (limited to 'x11-libs/gai/gai-0.5.6.ebuild')
-rw-r--r--x11-libs/gai/gai-0.5.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/gai/gai-0.5.6.ebuild b/x11-libs/gai/gai-0.5.6.ebuild
new file mode 100644
index 000000000000..ffc2e0503843
--- /dev/null
+++ b/x11-libs/gai/gai-0.5.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/gai-0.5.6.ebuild,v 1.1 2004/10/08 16:37:54 lordvan Exp $
+
+IUSE="opengl gnome"
+
+MY_P=${P/_/}
+DESCRIPTION="GAI, The General Applet Interface library is a library that will help applet programmers a lot."
+HOMEPAGE="http://gai.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gai/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ppc"
+
+DEPEND=">=x11-libs/gtk+-2.0.0
+ opengl? ( >=x11-libs/gtkglext-1.0.5 )
+ gnome? ( >=gnome-base/gnome-panel-2.0.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # works with just set prefix (doesn't hardcode the prefix anywhere)!
+ local myconf
+
+ # Someone please tell upstream that the way to enable/disable things in
+ # configure scripts should be bloody well consistent -- it's in poor taste
+ # and downright incompetent to have to use --with if you want something
+ # and --disable if you don't
+
+ use opengl \
+ && myconf="${myconf} --with-gl" \
+ || myconf="${myconf} --disable-gl"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ econf \
+ --prefix=${D}/usr \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS BUGS COPYING.LIB ChangeLog INSTALL README \
+ README.gai THANKS TODO WINDOWMANAGERS
+ dohtml ${S}/docs/*
+ # install examples
+ cp -r ${S}/examples ${D}/usr/share/doc/${P}
+}