summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-08 15:13:58 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-08 15:13:58 +0000
commitc0f8da43bfc751101d1301a426387e688547042b (patch)
treedc61f51429d05aedd6f2009bdbb68be3ad2789bd /x11-drivers
parentalpha/ia64/sh/sparc stable wrt #418905 (diff)
downloadgentoo-2-c0f8da43bfc751101d1301a426387e688547042b.tar.gz
gentoo-2-c0f8da43bfc751101d1301a426387e688547042b.tar.bz2
gentoo-2-c0f8da43bfc751101d1301a426387e688547042b.zip
Add patch to fix dga failure, bug #425322.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-dummy/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-dummy/files/xf86-video-dummy-0.3.5-dga-support.patch49
-rw-r--r--x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.5-r1.ebuild28
3 files changed, 85 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-dummy/ChangeLog b/x11-drivers/xf86-video-dummy/ChangeLog
index de2f51a1c6d6..ddadc4f7e0a6 100644
--- a/x11-drivers/xf86-video-dummy/ChangeLog
+++ b/x11-drivers/xf86-video-dummy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-dummy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-dummy/ChangeLog,v 1.76 2012/06/29 04:20:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-dummy/ChangeLog,v 1.77 2012/07/08 15:13:58 chithanh Exp $
+
+*xf86-video-dummy-0.3.5-r1 (08 Jul 2012)
+
+ 08 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-video-dummy-0.3.5-dga-support.patch,
+ +xf86-video-dummy-0.3.5-r1.ebuild:
+ Add patch to fix dga failure, bug #425322.
29 Jun 2012; Markus Meier <maekke@gentoo.org> xf86-video-dummy-0.3.5.ebuild:
arm stable, bug #419473
@@ -320,4 +327,3 @@
08 Aug 2005; Donnie Berkholz <dberkholz@gentoo.org>;
+xf86-video-dummy-0.1.0.ebuild:
Initial commit for modular X.
-
diff --git a/x11-drivers/xf86-video-dummy/files/xf86-video-dummy-0.3.5-dga-support.patch b/x11-drivers/xf86-video-dummy/files/xf86-video-dummy-0.3.5-dga-support.patch
new file mode 100644
index 000000000000..e4a848e69a95
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/files/xf86-video-dummy-0.3.5-dga-support.patch
@@ -0,0 +1,49 @@
+From 02918fd53434a23a72fe878a90f4ec48ef0e0416 Mon Sep 17 00:00:00 2001
+From: Jeremy Huddleston <jeremyhu@apple.com>
+Date: Mon, 09 Jan 2012 09:00:40 +0000
+Subject: Don't use XFreeXDGA to determine DGA support
+
+If our server supports DGA and we want to build the dummy driver without it,
+XFreeXDGA will be defined by the server and will be picked up rather than
+our configuration option. This change forces us to honor our configuration
+hoice.
+
+Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
+---
+diff --git a/configure.ac b/configure.ac
+index d92e22a..6861485 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -61,7 +61,7 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
+
+ if test "x$DGA" = xyes; then
+ XORG_DRIVER_CHECK_EXT(XFreeXDGA, xf86dgaproto)
+- AC_DEFINE(XFreeXDGA, 1, [Support DGA extension])
++ AC_DEFINE(USE_DGA, 1, [Support DGA extension])
+ fi
+ AC_SUBST([DGA])
+ AM_CONDITIONAL([DGA], [test "x$DGA" = xyes])
+diff --git a/src/dummy_driver.c b/src/dummy_driver.c
+index 041ca96..6533b27 100644
+--- a/src/dummy_driver.c
++++ b/src/dummy_driver.c
+@@ -45,7 +45,7 @@
+ #include <X11/Xproto.h>
+ #include "scrnintstr.h"
+ #include "servermd.h"
+-#ifdef XFreeXDGA
++#ifdef USE_DGA
+ #define _XF86DGA_SERVER_
+ #include <X11/extensions/xf86dgaproto.h>
+ #endif
+@@ -592,7 +592,7 @@ DUMMYScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
+
+ xf86SetBlackWhitePixels(pScreen);
+
+-#ifdef XFreeXDGA
++#ifdef USE_DGA
+ DUMMYDGAInit(pScreen);
+ #endif
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.5-r1.ebuild b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..daab54cf0d4d
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.5-r1.ebuild,v 1.1 2012/07/08 15:13:58 chithanh Exp $
+
+EAPI=4
+inherit xorg-2
+
+DESCRIPTION="X.Org driver for dummy cards"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="dga"
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ dga? (
+ x11-proto/xf86dgaproto
+ )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dga)
+ )
+ xorg-2_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-dga-support.patch
+)