summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-02-24 06:03:10 +0000
committerMarien Zwart <marienz@gentoo.org>2007-02-24 06:03:10 +0000
commita725f9301c4c2b01f15912cb9d80a78e050d2a89 (patch)
tree3946e9c50963084258dd2c5d70fc4bee43a9d7d2 /x11-drivers
parentEnsure JVM stack size is sufficient to run JPL test-suite on 32bit ppc. (diff)
downloadgentoo-2-a725f9301c4c2b01f15912cb9d80a78e050d2a89.tar.gz
gentoo-2-a725f9301c4c2b01f15912cb9d80a78e050d2a89.tar.bz2
gentoo-2-a725f9301c4c2b01f15912cb9d80a78e050d2a89.zip
Apply a patch from desbaine@yahoo.com to fix bug #168163: make ati-drivers compile if a previous version is not installed.
(Portage version: 2.1.2-r10)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog6
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild10
2 files changed, 11 insertions, 5 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index c587a236e775..ade2bde82075 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.65 2007/02/22 22:24:22 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.66 2007/02/24 06:03:10 marienz Exp $
+
+ 24 Feb 2007; Marien Zwart <marienz@gentoo.org> ati-drivers-8.34.8.ebuild:
+ Apply a patch from desbaine@yahoo.com to fix bug #168163: make ati-drivers
+ compile if a previous version is not installed.
*ati-drivers-8.34.8 (22 Feb 2007)
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild
index 1f4f594cf495..e4cf2095498b 100644
--- a/x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild,v 1.1 2007/02/22 22:24:22 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.34.8.ebuild,v 1.2 2007/02/24 06:03:10 marienz Exp $
IUSE="acpi qt3"
@@ -170,20 +170,22 @@ src_compile() {
# The -DUSE_GLU is needed to compile using nvidia headers
# according to a comment in ati-drivers-extra-8.33.6.ebuild.
"$(tc-getCC)" -o fgl_fglxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU \
+ -I"${S}"/common/usr/include \
-lGL -lGLU -lX11 -lm fgl_glxgears.c || die "fgl_glxgears build failed"
einfo "Building fglrx_gamma lib"
cd "${S}"/extra/lib/fglrx_gamma
"$(tc-getCC)" -shared -fpic -o libfglrx_gamma.so.1.0 ${CFLAGS} ${LDFLAGS} \
- fglrx_gamma.c -DXF86MISC -Wl,-soname,libfglrx_gamma.so.1.0 \
+ fglrx_gamma.c -DXF86MISC -Wl,-soname,libfglrx_gamma.so.1.0 -lXext \
|| die "fglrx_gamma lib build failed"
ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so || die "ln failed"
ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1 || die "ln failed"
einfo "Building fglrx_gamma util"
cd "${S}"/extra/programs/fglrx_gamma
- "$(tc-getCC)" -o fglrx_xgamma ${CFLAGS} ${LDFLAGS} fglrx_xgamma.c \
- -lm -lfglrx_gamma -lX11 -lXext -L../../lib/fglrx_gamma \
+ "$(tc-getCC)" -o fglrx_xgamma ${CFLAGS} ${LDFLAGS} \
+ -I../../../common/usr/X11R6/include -L../../lib/fglrx_gamma \
+ fglrx_xgamma.c -lm -lfglrx_gamma -lX11 \
|| die "fglrx_gamma util build failed"
if use qt3; then