summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-01-13 08:55:49 +0000
committerRémi Cardona <remi@gentoo.org>2008-01-13 08:55:49 +0000
commit8238af103e08b7f93f3c8f7ad0221b4691cae1b4 (patch)
tree68c528dd31eb9ad976240d6f5874155beb560b4a /x11-drivers
parentarm/s390/sh stable (diff)
downloadgentoo-2-8238af103e08b7f93f3c8f7ad0221b4691cae1b4.tar.gz
gentoo-2-8238af103e08b7f93f3c8f7ad0221b4691cae1b4.tar.bz2
gentoo-2-8238af103e08b7f93f3c8f7ad0221b4691cae1b4.zip
x11-drivers/xf86-video-i810: Add patch to fix build with USE=-dri (see bug #103192)
(Portage version: 2.1.4)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-i810/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-i810/files/xf86-video-i810-2.1.1-fix_build_without_dri.patch35
-rw-r--r--x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild9
-rw-r--r--x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild5
4 files changed, 51 insertions, 5 deletions
diff --git a/x11-drivers/xf86-video-i810/ChangeLog b/x11-drivers/xf86-video-i810/ChangeLog
index 55806b71067c..00fafd699bb0 100644
--- a/x11-drivers/xf86-video-i810/ChangeLog
+++ b/x11-drivers/xf86-video-i810/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-i810
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/ChangeLog,v 1.69 2008/01/10 14:28:55 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/ChangeLog,v 1.70 2008/01/13 08:55:48 remi Exp $
+
+ 13 Jan 2008; Rémi Cardona <remi@gentoo.org>
+ +files/xf86-video-i810-2.1.1-fix_build_without_dri.patch,
+ xf86-video-i810-2.1.1.ebuild, xf86-video-i810-2.2.0-r1.ebuild:
+ Add patch to fix build with USE=-dri (see bug #103192)
10 Jan 2008; Daniel Gryniewicz <dang@gentoo.org>
xf86-video-i810-2.1.1.ebuild:
diff --git a/x11-drivers/xf86-video-i810/files/xf86-video-i810-2.1.1-fix_build_without_dri.patch b/x11-drivers/xf86-video-i810/files/xf86-video-i810-2.1.1-fix_build_without_dri.patch
new file mode 100644
index 000000000000..bc06c9755b04
--- /dev/null
+++ b/x11-drivers/xf86-video-i810/files/xf86-video-i810-2.1.1-fix_build_without_dri.patch
@@ -0,0 +1,35 @@
+From: Jesse Barnes <jbarnes@hobbes.virtuousgeek.org>
+Date: Thu, 3 Jan 2008 19:16:15 +0000 (-0800)
+Subject: Fix compilation error when not using DRI
+X-Git-Url: http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=commitdiff;h=f2ffc0f6e038357dda268363e52c11ada1d0b810
+
+Fix compilation error when not using DRI
+
+This patch complements 88f8b688e2316ae4a1f7485f0010ce90de54783a which
+added uint64_t typed variables to avoid unsigned long overflows in
+32-bit architectures but didn't include <stdint.h> with the required
+definition.
+
+When XF86DRI and _XF86DRI_SERVER_ are defined this header gets
+indirectly included through "i830_dri.h", thanks to "i830_common.h"
+which masquerades this problem as released in 2.1.0 and that manifests
+with :
+
+In file included from i810_driver.c:88:
+i830.h:137: error: expected specifier-qualifier-list before 'uint64_t'
+i830.h:240: error: expected specifier-qualifier-list before 'uint64_t'
+
+Patch from Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe>
+---
+
+--- a/src/i830.h
++++ b/src/i830.h
+@@ -40,6 +40,8 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ #define I830DEBUG
+ #endif
+
++#include <stdint.h>
++
+ #ifndef REMAP_RESERVED
+ #define REMAP_RESERVED 0
+ #endif
diff --git a/x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild b/x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild
index 00ecd6cd6152..eda3d6c165fd 100644
--- a/x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild
+++ b/x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild,v 1.3 2008/01/10 14:28:55 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-2.1.1.ebuild,v 1.4 2008/01/13 08:55:48 remi Exp $
# Must be before x-modular eclass is inherited
# Enable snapshot to get the man page in the right place
@@ -8,7 +8,7 @@
#SNAPSHOT="yes"
XDPVER=-1
-inherit x-modular
+inherit x-modular eutils
# This really needs a pkgmove...
SRC_URI="http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-${PV}.tar.bz2"
@@ -34,6 +34,11 @@ DEPEND="${RDEPEND}
CONFIGURE_OPTIONS="$(use_enable dri)"
+src_unpack() {
+ x-modular_unpack_source
+ epatch "${FILESDIR}/${PN}-2.1.1-fix_build_without_dri.patch"
+}
+
pkg_setup() {
if use dri && ! built_with_use x11-base/xorg-server dri; then
die "Build x11-base/xorg-server with USE=dri."
diff --git a/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild b/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild
index fe5cc78d4bbd..a3acc4eccf38 100644
--- a/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild
+++ b/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild,v 1.1 2007/12/27 16:36:52 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.0-r1.ebuild,v 1.2 2008/01/13 08:55:48 remi Exp $
# Must be before x-modular eclass is inherited
# Enable snapshot to get the man page in the right place
@@ -37,6 +37,7 @@ CONFIGURE_OPTIONS="$(use_enable dri)"
src_unpack() {
x-modular_unpack_source
epatch "${FILESDIR}/${PN}-2.2.0-fix_xv_segfault.patch"
+ epatch "${FILESDIR}/${PN}-2.1.1-fix_build_without_dri.patch"
}
pkg_setup() {