summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-04-17 10:43:49 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-04-17 10:43:49 +0000
commit726d29946c82e337164e2f62276903089ab69676 (patch)
treedf63b463dfee137daab565aadba0fd53d3338bbc /x11-drivers
parentVersion bump (diff)
downloadgentoo-2-726d29946c82e337164e2f62276903089ab69676.tar.gz
gentoo-2-726d29946c82e337164e2f62276903089ab69676.tar.bz2
gentoo-2-726d29946c82e337164e2f62276903089ab69676.zip
Version bump to latest in 6.12.x series. With kind permission from scarabeus.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog9
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.12.7.ebuild54
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index cc7237cd2f1a..7e7180de037c 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.112 2010/04/16 21:20:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.113 2010/04/17 10:43:49 polynomial-c Exp $
+
+*xf86-video-ati-6.12.7 (17 Apr 2010)
+
+ 17 Apr 2010; Lars Wendler <polynomial-c@gentoo.org>
+ +xf86-video-ati-6.12.7.ebuild:
+ version bump to latest in 6.12.x series. With kind permission from
+ scarabeus.
16 Apr 2010; Pacho Ramos <pacho@gentoo.org> xf86-video-ati-6.12.6.ebuild:
amd64 stable, bug 308521
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.7.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.7.ebuild
new file mode 100644
index 000000000000..4a3c18b19ec7
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.7.ebuild,v 1.1 2010/04/17 10:43:49 polynomial-c Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+EAPI=2
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+#SRC_PATCHES="http://dev.gentooexperimental.org/~scarabeus/${PV}-patches-01.tar.bz2"
+SRC_URI="${SRC_URI}
+ ${SRC_PATCHES}"
+
+RDEPEND=">=x11-base/xorg-server-1.2[-minimal]"
+DEPEND="${RDEPEND}
+ >=x11-libs/libdrm-2
+ x11-proto/fontsproto
+ x11-proto/glproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86driproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+"
+CONFIGURE_OPTIONS="--enable-dri"
+
+src_prepare() {
+ x-modular_src_prepare
+ if [[ -n "${SRC_PATCHES}" ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+}